Occasionally freezing when scanning through radio frequencies

Bug Description

When I enter the sample mode on the Polyend Tracker, and I select radio, and I start scrolling through frequencies, or use the scan, the device sometimes freezes up and becomes unresponsive.

Reproduction Steps

  1. Enter sample recorder
  2. Select radio
  3. Start scanning frequencies, use jog wheel or search, do this often when the device is “busy” trying to scan for a signal
  4. The device freezes, and only USB disconnect works to get it back to work


This bug is so frequent that I always save my project before I even attempt radio sampling. It happens almost always once when I am trying to scan frequencies.

I am in the Netherlands, not sure if the DAB+ signals, plus scarce radio sources or location are interfering, but so you know.

Found in

  • Version: 1.6
  • Build: ?

Have you tried to reflash the firmware? I don’, have any issue with radio sampling

This has happened to me once on the current firmware. I was flicking through the stations pretty fast and the Tracker froze up.


Yes this is exactly what happens. When there are not much channels to choose from (poor reception) it seeks, and while seeking / tuning it happens that it freezes up. When it is on a certain frequency, it will keep on working.

It is even more annoying. I can’t scan to certain frequencies with this bug! There is no way to manually input the desired frequency, and when I deliberately try to skip to the 92.2 FM frequency, it consistently freezes up the device around 90.x FM.

I like the concept, but the implementation is really broken. I’d rather buy a second hand FM tuner with aux out and not use the on board radio tuner which is a shame as I do like to sample local radio stations.

@jorgen.bodde I’m sorry you are experiencing issues with Tracker. I tried to reproduce this bug to no avail. Could you downgrade the firmware to 1.5 and see if it happens as well?

PolyendTracker_1.5.0.zip (940.7 KB)

1 Like

Hi, sorry for the late reply, I was on holiday.

I tried both, and both firmware(s) crash. It seems the 1.5.0 FW is a bit more stable, but I got it to crash as well. It has to do with the frequent seeks and somehow it freezes up when seeking.

It also seems to do this without any headphones so I think the issue is not the lack of channel selection, it just freezes up, even on/off don’t work. That looks to me (developer hat on here) that the main loop of receiving input and acting on it, is somehow frozen or compromized. Not sure of the internal architecture, but it’s completely unresponsive. The radio still plays when it finds something, so that part keeps working but I assume that’s just the chip still outputting audio.

The reproduction videos can be found on the following Google Drive links. As you can see it took me about 10 seconds to get it to crash on FW 1.6 and a good long time on FW 1.5 so there is definately a stability issue.

I hope it can be fixed as I bought the device where 1/3rd of my decision was this usecase (sampling from the radio, to make beats), and it seems very unstable.

It there is any beta I can test while you guys diagnose this, let me know I am happy to help.

FW 1.6 – (instant crash)

FW 1.5 – (at approx 2m 11s)

Any progress on identifying this bug? I am considering returning this device to the vendor as it was one of the main selling points and it is horribly bugged.

If you want me to try a firmware with logging enabled, reproduce it and send you the logs, let me know.

@jorgen.bodde Finally, we managed to reproduce it. We will try to repair it as soon as possible.


Thank you very much! I hope that the movies were of help reproducing it!

1 Like

I thought I would add my own experience with this, as I am using American frequencies. The problem occurred in both firmwares 1.6 and 1.7.

If I scan, there is no problem, but if I use the jog wheel to adjust the frequency, it freezes/crashes if I scroll up to 93.9 Mhz or, if I scan past this frequency, if I scroll down to 94.3 Mhz. Every time, it is these same frequencies which cause it to freeze/crash.

I can provide video, if that is helpful.

1 Like

I am having this issue too. Freezes each time when using up & down arrows or jog wheel on particular US stations.

I have good hopes that the fix will come on 1.8. The devs seemed to have found it, but it was not yet fixed on 1.7.

Exact same problem here.
Got my tracker a few days ago with 1.6.
I tried to use the radio, unit freezes when dialing higher than 90.3.
Although it was claimed the radio freeze was fixed in 1.6:

  • Freezes in Sample Recorder while using FM radio are now fixed.
    (quote from the website)

So I installed 1.7, but radio is still crashing the unit and making it

I get the same crash every time, freezes at varying frequencies between 90-99MHz, whether scanning fast or slow with jog wheel or arrows keys. I have to unplug from power to reset. Same story in firmwares 1.6, 1.7, and 1.7.1. A friend of mine also could not repeat the issue, he has an older unit, mine is newer from the recent Reveb.com sale, perhaps its hardware related?

I can confirm 1.7.1 Freezing on reaching higher than 90-95 Mhz :face_with_diagonal_mouth:

Yes, as mentioned in some other topic the fixing of the radio was not planned for this patch.

I was having this issue with 1.6, 1.7 and now 1.7.1. Was hoping the firmware updates would fix it. Seems to happen when I hit above 93.9, but I’m wondering if maybe it has to do with the text it’s trying to load from some stations?

I cannot reproduce this issue with v1.7.1 going through the whole frequency range.

It’s got something to do with the hardware version of the tracker.

Is yours an older one?