USB MIDI with Android

Hi all. I’m really loving my Tracker Mini, but I can’t for the life of me get a MIDI controller to work with it. I have tried various physical devices and a phone app (MIDI keyboard on Android). I’m going in via the USB C port. I thought USB C to USB C should be simple. I have set the MIDI note input to USB and I have tried turning the Mini on with the USB lead already connected. I have also set the default USB setting to MIDI on my phone.

I’m sure it’s just me doing something stupid, so if anyone can point me to something that explains what I need to do in simple language, I would really appreciate it.

Alternatively, if anyone can recommend a compact controller that I can put in my bag to use on the go, that would be great - although it would be more convenient to use my Samsung S22 Ultra or my iPad Pro (both of which have USBC sockets).

Sorry to pitch straight in with a plea for help - I’m still learning, so don’t have much to contribute at the moment!

Is this the Keyboard you were using?

If so, that’s the one i use, as well. On Android when connecting the Mini via USB-C, it should show up as “Polyend Tracker Mini” in the MIDI Output Destinations.

If that’s not the case, try a different cable, since the one you are using may just do power delivery and not data.

As for MIDI Settings on the Tracker - just make sure that Notes In is set to USB or USB + Midi In jack and that the Notes In channel is set to ALL.

1 Like

That’s the one! Thank you. I’ll try a different cable, as those are the settings I used.

1 Like

Unfortunately, I still can’t work it out. The cable seems okay, because Tracker Mini shows in the media output list. However, it doesn’t appear in the MIDI output list in the MIDI keyboard app. I have set MIDI as the default USB configuration in my phone settings. I have tried every conceivable sequence of connecting/disconnecting and restarting. Not sure what else I can try.

If it’s an issue with my phone, I’m happy to use any portable keyboard. I just need to be able to play notes in. The problem I’m finding is that every keyboard I can find is powered by USB, which doesn’t work with the Tracker Mini.

I guess I must be doing something pretty stupid - I just don’t know what.

Mine’s actually not set to MIDI. Try to set it to regular Charging or MTP and see if that helps.

Thanks again - I really do appreciate all your help. I gave that a try and unfortunately it didn’t work.

I have now also tried a couple of apps on my iPad. This went a bit better, as they both saw the Tracker in their MIDI out settings, but in each case they effectively just sent audio, rather than MIDI.

I’ll have another look at it all tomorrow, I guess.

1 Like

Of course, happy to help if i can. I’m sure we’ll get it to work eventually, darn technology and all :laughing:

Check this Post here:

There’s some instructions there as well. I’ve managed to get it working with AUM and a Moog App.

If there is anything else i can help with, just let me know. :blush:

As far as MIDI Keyboards go, the Arturia Minilab is pretty handy, but as you mentioned, USB Power Delivery is not there. But it works well if you use a powerbank and a regular MIDI Jack cable.

Definitely not as small and portable as a phone or tablet though :laughing:

Hi Sandroid, I’m having problems too.I have the Midi Keyboard app installed on my Oneplus 7 pro and the tracker mini shows up on the midi output, but when i select it and OK it I get an error message saying “could not open port:in use or unavailable”.

I was going to cancel this comment because it’s working now, but i thought I would just let anyone else getting this problem know that you have to arm the track(highlight orange). Obvious you might think, but hey we are not all whiz kids :grin::grin::sunglasses:

2 Likes

Hey fellow OnePlus 7 user! :blush:
I got a 7 as well, but just the regular one.
We would have figured that problem out pretty quick i’d say :laughing:

Thanks for posting the solution to your problem though! :heart:

Thanks all - I haven’t been arming the track - will see if that helps!

Nothing seems to make any difference. I’m actually wondering if I have a faulty unit. It’s not really much use to me if I have no keys to record live.

What device are you using and what app? Gimme as much details as possible :laughing:
This way i can suggest maybe some things you could try.

Thanks, Sandroid! I’m using the same Android app as you and my phone is a Samsung Galaxy S22 Ultra. I have tried several different leads. This is my preferred choice as I obviously always have it with me. I can’t even get the Mini to show up in this one.

I have also tried my iPad Pro (not sure which one, but it’s about 5 years old and has a USB-C, port) along with the Moog app. The mini appears, but MIDI doesn’t work.

I did also try a lumi keyboard and another one from our studio last week. Would need to check that one again.

Ah sorry @smounteney, you’ve already mentioned the devices. One thing i am curious though, what Firmware is your Mini running on? You should be able to find that info in Config → Firmware.

It should be 1.0.0 Build 492. I’m asking this because mine arrived with the wrong Firmware.

I’m probably going to record a video today regarding Mini and iOS/Android and all the things i’ve learned so far.

It’s running the same as yours, unfortunately. :face_with_diagonal_mouth: I personally think a video on this subject would be a great idea. Thanks again for your help.

Some new information has come to my attention, so i’m sharing it here for completeness sake:

Thanks, Sandroid. That explains a lot! I guess we will have to wait and see if there’s a fix, now?

Annoyingly I still can’t get my iPad Pro to work, either, but I guess that’s me doing something stupid.

I’m hoping to possibly get this issue through to a vote on the wishlist thread. If you’d like to chime in, please do: Built-in MIDI keys/pads for the Tracker Mini

Just to add another voice and some information - I have a similiar issue. I have a Samsung Galaxy A53 5G with Android 14 on board. I use the same keyboard app. When I connect tracker I get some “toast” that it has been connected, but I cannot select is as a input nor output device. What is interesting, it can convey audio signal from this app to trackers line out (I can hear piano in the speakers). Cable also seems to be working fine, since I was able to connect Behringer JT-4000 micro and have a full duplex communication with app.