Sending USB MIDI to Tracker Mini via iPhone

Trying to recreate Iso’s video on the Polyend Youtube channel of him using the Moog Model D app to input notes on the Tracker Mini. I’ve got an iPhone 11 running iOS 16.6 connected to my mini using the supplied USB A to USB C cable and an Apple lightning to USB3 camera adapter. I’ve also tried connecting straight from phone to mini via a lightning to USB C cable. On the mini I’ve turned it on to receive notes from USB. Neither ways of connecting my phone to the mini will allow me to input MIDI data like Iso’s video. What am I missing? Should I just buy a USB to MIDI convertor like this?

Sadly i don’t have an iPhone to test myself. But i have connected an iPad Pro (M1) successfully to the Mini.

If i would have to guess… is there a setting in the Model D app that lets you set where to send the MIDI Output to? You should see the Tracker there, unless some security setting prevents the app from seeing the Tracker.

I do have the Model 15 App on the iPad, i’ll check if they got a setting hidden away somewhere. I imagine the core functionality may work the same way between these two apps.

Alright, i just checked on the Model 15 app on the iPad. There’s settings on the top right.
Within those settings you should have a MIDI Tab and there you should be able to choose the Tracker Mini as an Output.

This of course will only be the case if Moog decided to implement the same MIDI Settings on the Model D app :blush:

I tried browsing for screenshots for the Model D app and it does look like the Settings are structured very similarly:

Thanks for checking this out! I’ve opened up the MIDI config screen in the Model D app (also tried Model 15 and Animoog Z app) but I’m not seeing the Tracker Mini as an output option on any of the apps. Would you mind sharing your MIDI config screen on the Tracker Mini to see if I’ve got that all set up correctly as well?

Of course, here you go:

:information_source: Small Tip:

  • Turn off the Tracker
  • Connect the USB Cables
  • Then turn on the Tracker

Hopefully this will help the iPhone to recognize the device. If i remember correctly, there should be a prompt asking you if it’s ok to allow the USB Accessory to be used.

I’m also pinging @iso , since he has an iPhone and connected the two before. Hopefully he can guide you if that doesn’t work :blush:

I’ve matched all your settings and still no luck getting the mini to show as a MIDI output (or input) on my iPhone. Also I’ve run through every possible combination of cord and adapter I have at the house. At this point I’m kind of thinking my iPhone might be the culprit. I’ve noticed in Iso’s video they are using an older model iPhone (no cutout) so maybe it’s got something to do with the current iOS. Just to be clear I’ve got no issues sending MIDI into the mini via USB connected to my MacBook Pro, or controlling synths in Ableton with MIDI running out of the mini.

Hmm. you might be on to something…

My iPad Pro (M1) is on the latest OS and those already use USB-C instead of Lightning.
So you are right, it might just be some arbitrary iPhone/iOS weirdness.

Let’s hope someone with an iPhone can chime in! :crossed_fingers: :heart:

1 Like

Hey, I’ve just tested on a Model D app with iphone 12 mini and the same adapter I’ve made this video with:

And sadly I can’t make it work on 16.6:(


I found a couple articles online, claiming that iOS 16.5 seems to have broken this feature.

I couldn’t find any information in the latest iOS Release Notes, whether this has been fixed or not.

:information_source: This does not affect newer Apple devices with USB-C ports. Seems to be exclusively on devices that still have the Lightning port.


Appreciate the online sleuthing Sandroid! I’ll keep my fingers crossed for an update from Apple to fix the issue.

1 Like

Update: I’ve tried again with the Model D app with 16.6 ios on 12 mini, set everything (even the clock out to USB), ran the app, and then connected the Mini. The app then recognized the unit immediately. Also, please try different cables, that might be a thing here.


Success finally! I ended up ordering some Lightning to USB A adapters from Amazon. This combined with the included Polyend cable is all it took to get my phone to recognize the mini.

Also quick shout out to the Midi Poly Grid app. So far it’s been a great grid based solution for sending MIDI to the mini. So much fun to chop up samples and be able to play them back in a similar fashion to the OG.


My guess the Lightning to USB-C cable you initially used would probably only transfer power and maybe analog audio in some cases.

To trigger Lightning connector’s « host mode » you need a Lightning to USB-A adapter typically provided by Apple then a standard USB cable.

Oh man, been struggling with this for a week as well. This thread gives me hope, but no luck over here. Hilarious because my next step was pivoting to a lightning to midi interface, the exact one that @corysnyd linked to at the start of this thread. It is chilling in my Amazon cart waiting for me to pull the trigger. Before I blow any more money, any help appreciated!

My specs:

IPhone 12
iOS 16.6.1
Model D app (as well as multiple others I’ve tried that have midi out settings)
Proper MIDI settings on the Mini (I’ve tried just “Notes in” Set to USB, as well as the nuclear, every option set to USB)
Official Polyend USB to USB-C cable that came with the device (as well as every other one in my house)
Paired with a lightning to USB camera adapter (I’ve tried two):
-The Apple official
-My best visual guess in what @iso used in the YouTube vid

Apple Lightning to USB Camera Adapter, USB 3.0 OTG Cable for iPhone/iPad to Connect Card Reader, USB Flash Drive, U Disk, Keyboard, Mouse, Hubs, MIDI, Plug & Play

Both of those adapters and the cable work fine with another device (a launchpad pro)

I’ve tried every combo of powering up and plugging in and vice versa.

For the life of me, “Tracker Mini” never announces itself in my Model D app midi settings. So I’m not able to select it as a midi output :cold_sweat:

The setup works like a charm with my launchpad pro (announces itself as in/out option in model d app). So I’m starting to think it’s something with the Mini or with handshaking between the two Mini and IPhone with above specs.

Any help appreciated!!

One more thing - try resetting your phone. That helped me. Also, I wasn’t using the Poly cable when testing for the second time. So pls try non-Poly cable and turning off and on your phone.

1 Like

I never ended up ordering that Lightning to MIDI adapter linked in my original post on this thread. Like you I tried every possible cable and adapter in my house with no luck (including the Apple CCK). The adapter that ended up working for me was this one from another post in this thread, Lightning to USB A.

This adapter has been my solution to the problem. It’s allowed me to use any USB A to USB C cable I’ve tried with it flawlessly. Plus you get two of them for a pretty reasonable price. Good luck!


Thanks for the responses @iso and @corysnyd
I have tried restarting my iPhone multiple times. I tried 3 diff USB cables I had (including Polyend official). I also tried an old iPhone 7 on iOS 15. No luck with any! I just pulled the trigger and ordered the same adapter as you @corysnyd. Will update you on how it goes. Thanks all!!

@corysnyd Just received the two pack of the adapters you linked. They worked!! Plugged everything in (using official Polyend power cable), powered on the Mini and “Tracker Mini” popped up as an option in the Model D app. What a beautiful thing to finally see lol. $60 worth of adapter later :sweat_smile:. Thank you so much!!!


This is a very good example of what a mess the USB Specifications and Versions have become :see_no_evil:

Glad you finally got it working :partying_face: Now go forth and have fun fellow tracker’er! :v:


Hello everyone,

Been following the MIDI threads a lot and I haven’t really got any of my MIDI devices working, until today.

iPhone 15 USB-C cord that comes with the phone works flawlessly. Until today, nothing I have tried with my iPhone 12 worked at all, tons of adapters, etc…

I tried the USB-C to USB-C cord that came in the iPhone 15 box and the Model-D app showed the tracker right away.

Now I can’t figure out how to have the audio stop playing through USB audio instead of the tracker audio, but I really haven’t messed with it much.

Tracker records the midi, can’t hear it until I unplug the cord. Anyways, thought I’d share.