Tracker Mini (or Play+) not recognized via USB on AMD CPUs

Bug Description

Over multiple weeks and testing many PCs, Macs using many cables and configurations of USB hubs I have evidence that supports that Mini USB connection does not work on AMD CPUs.

Reproduction Steps

  1. Find Windows PC with an AMD CPU

  2. Connect Tracker Mini, turned on.

  3. Navigate to device manager.

  4. No Polyend Tracker Mini

  5. Find Windows PC with an Intel CPU

  6. Connect Tracker Mini, turned on.

  7. Navigate to device manager.

  8. Tracker Mini connected under Audio devices

  9. Find Mac

  10. Connect Tracker Mini, turned on.

  11. Navigate to Settings > Sound

  12. Tracker Mini available as input and output device

Occurrence

bug is reproducible always

Found in

  • Version: [1.0.0]
  • Build: [492]

Attachments



Curious to know how many Intel and AMD CPUs you tested. Can you share the models you tested on if possible?

I have tested on four AMD machines and two Intel machines.
All builds are custom. Two AMD are personal PCs, one with a Ryzen 9 and with a Ryzen 5. Two AMD are professional media computers with CPU specs as above.
Both Intel machines are are Dells with similar with specs as listed in the image above.

All Intel machines have worked, all AMD machines have not worked.

Thanks for sharing those details. I am sure it will bring some value and insight into getting to the core of this issue.

I can confirm that both the Tracker Mini and the Play+ are not recognized on my AMD (Ryzen 9) computer when connected directly to the board. Through a powered USB-Hub however they do connect, which is also curious. I’ve tried two Hubs with the same outcome, the devices connect only when connected through a hub.

On two Intel CPU computers i have, both devices are recognized immediately
I assumed this was just a problem with my windows config up until now :laughing:

i’ve changed the title to reflect that the entire device is not recognized. Not just USB Audio - it’s the entire device that does not show up.

1 Like

Great! Thank you.
I’ll have access to a hub tomorrow. I’ll do a test and report back

Hi @carlinplumb , thanks for taking the time to report the bug in such detail. Sorry you’re having problems with Mini when using it with some of your computers. It sounds like this could be motherboard-dependent, or USB chipset and its drivers, more specifically. You could try updating your motherboard’s USB and chipset drivers to check if it solves the issue? Thanks for your support

I’ve updated my Board and the AMD Drivers to the latest version. Here’s some info on my setup:

  • Mainboard: ASUS ROG STRIX X570-F GAMING
  • Processor: AMD Ryzen 9 3900X 12-Core

The results are as follows:

  • Connecting the (Mini / Play+) directly to the Mainboard → devices are not recognized
  • When connecting through a powered Hub → devices get recognized

I have two powered hubs that i’ve tested this with:

  • a powered 3.0 USB Hub
  • an older powered Hub that has 3.0 and 2.0 USB connections.

With both Hubs i can get the Mini and Play+ to connect to the computer. Without the hubs - no chance.

In my case i will not exclude a possibility that my Windows 11 setup might be weird and that this is completely a problem of my setup. I’ll report back in the future when i finally decide to reinstall my entire setup :laughing:

I would rule out motherboard or USB drivers. All AMD computers used have different motherboards and different CPUs, all with the latest drivers.

After not working my own computer at home was fully updated to test. Including a BIOS update. I even updated to windows 11 to see if that would help.

The fact I have a range of computers this is happening on makes me rule out any driver related issue.

I can now confirm that using a powered USB hub with one of the AMD computers that would previously not work, now works.

Intel computers remain the same.

This is not a solution however. A workaround at best.

this i find interesting. so it might not be my Windows setup after all.

It won’t connect to ANYTHING over usb that I’ve tried
AMD ryzen, google pixel 7 pro, and 7. Or a intel laptop.

Android is not supported at all (see here), which is totally understandable since the Android System is way to fragmented to support it meaningfully. I’ve managed to get it to connect with a OnePlus 7, but not with a Samsung S23.

The Intel Laptop is surprising atctually. Got some more specs for that thing?

I can also confirm that I had zero issues with my Play+ being recognized on my Intel desktop, but is not recognized on my AMD laptop. My laptop doesn’t seem to play friendly with my USB hub so sadly I cannot test that.

2 Likes

I just wanted to leave a comment saying I have the same problem with a Ryzen 5700U, and to put some pressure behind this problem.

In addition, I was trying to use it together with my MPC, but after 1 minute the audio seems to underrun the buffer, not recover, and all you hear is terrible digital noise.

Lastly, I can confirm that using USB passthrough on the MPC (basically acting as a powered USB hub) I can see the tracker on my laptop.

In addition, I can still connect the standard way with audio cables, but I’m a bit disappointed since I was looking forward to this feature upgrading from the OG tracker, and now it doesn’t work well on both of the devices I wanted to use it with… :confused:

1 Like

Ryzen 5 here.
Not seen by my win10 pc.

edit. passive hub in between solves this

1 Like

What model of hub are you putting in between, since the other comments seem to suggest it needs to be a hub with an external power source? I would love to resolve this issue for now by putting a basic usb adapter in the middle.

It’s this one, and i didn’t plug it into mains.

edit.
It did freeze on me while recording though.
But could be because i was also routing the audio to my daw and back to the Mini while monitoring from the Mini. I havent tested yet with a different outputdevice.
Asio4all can have a different in-and output.

You’re using Asio4all right?

Thanks for sharing. Interesting that it’s an active hub that can also be used passively :thinking:. I’m using Asio4all indeed, the tracker simply doesn’t show up (neither in device manager) without putting my MPC in the middle.