Tracker Mini (or Play+) not recognized via USB on AMD CPUs

same issue with my amd pc, play+ not shown in devices or detected by reaper no matter how connected. ( ryzen 7 2700x ,x470 asus MB) but no issue with my amd laptop(ASUS X513IA- ryzen 7 4700U)

I also have this issue - Tracker Mini. I also have AMD on x570 board and can confirm that the trick with powered hub works. Is there a chance it will be fixed with firmware update?

That being said I would like to point that the fact that for 8 days noone from support wouldn’t even said “Got your ticket, give me time” is just sad :frowning:

Thats weird. They re always very responsive and quick in replying to me. :thinking:

I’m also a bit amazed since my previous ticket from 2021 was answered in about an hour, while this time it was eight days (I’ve provided two updates with my findings). Maybe just something didn’t clicked in a bug tracker :wink:

Same for me: If plugged directly into computer, it doesn’t get recognised. Via USB hub (powered) all works just fine.

AMD Ryzen™ 5 5600X
ASRock A520M-ITX/ac
Ubuntu 23.10

Silly thing is i dont need to power it.
A passive hub works just as fine

Having the same issue with my AMD Ryzen 7 7840HS device doesn’t sow up and a message pops up saying that the USB device is not working properly. Tried a powered and an unpowered hub but neither worked

After updating from 1.01 to 1.1 firmware it now appears in asio4all

1 Like

I’m sad to say that it appears as though this bug may not be completely squashed. Here’s my setup:

OS: Windows 11 64-bit
MB: Gigabyte Aorus X570 Elite Wifi
Polyend Device: Tracker Mini (Firmware 1.1)

The symptom is that my OS does not detect the Tracker Mini at all. It doesn’t appear in Device Manager, anywhere in Settings. As a result, it doesn’t appear to ASIO-aware DAWs like Bitwig, nor does it show up as an available device in ASIO4ALL. The Tracker Mini appears to be receiving power from the USB connection in all cases.

My chipset drivers are current, I’ve tried USB 2.x and 3.x ports, USB-C, multiple cables (including the manufacturer-supplied one), reboots, etc. I don’t have a passive USB hub available, but my powered one also does not solve the problem.

Is anyone else still having this issue?

Update: I also tried connecting my Tracker Mini to a Mac on 14.5 (Sonoma). Starting to wonder if it’s a problem with my specific device. Potentially related to this issue?

I am having the same issue, but intermittently - I was able to get a successful USB connection yesterday, but with the same cable today nothing! Windows 10 (non-AMD), nothing showing up in the device manager or in ASIO4ALL. Tried a handful of different USB C to C cables, but I will see if I own any C to A.