Play+ Main encoder randomly jumping around. Anyone else experience?

Has anyone else encountered an issue with the Play+ main encoder suddenly switching settings at random? (video link here)
It suddenly started doing this today while prepping for my Jamuary entry for the day.
I tried switching out the power source (official wall-wart versus plugged into various battery banks), tried restarting the unit, tried removing and reinserting the SD card, etc, and nothing has corrected the situation.
I’m guessing this might be a hardware issue, but I would certainly hope not since I’ve only had this unit for three weeks at the very most.
This issue has pretty much rendered the unit completely unusable at this point, which is really saddening because I’ve grown to love the Play+ a great deal.
Is this something that is a software glitch or is this something that likely needs to be warrantied?

Hello @pianomanzero,

Thank you for reporting this bug. We are sorry you’re experiencing issues while using our product. Could you please read How to report bugs and edit your bug report?

Thank you. :slight_smile:

@pianomanzero Hi!

I already answered your email about a possible remedy to your issue. Let’s continue there.
Please, take a look at this topic: Play+ knob sensitivity: parameter values change without touching
Bending of the Sample/Folder knob should do the trick. :slight_smile:

hi @borsuk ! Thanks for that! So far it appears to have resolved the situation. Is this known to be a long-term solution? This unit has only ever been kept in an official case from Polyend, which is a tight fit. Was there any chance of the lid of the case being responsible for deforming the encoder?
Since this has happened to others, is there any long-term solution being implemented in manufacturing of future units?

This topic was automatically closed after 7 days. New replies are no longer allowed.