When using Fill in MIDI track, use Work-Step JACK Channel instead of default

When using Fill in MIDI track, use Current JACK Channel instead of defaulting to JACK CHANNEL 1 (or the one set up as default in the settings). Using a default value is useless if the user has more than 1 external device.

What is the problem?

If the user wants to try different fills for a MIDI track, each time the fill is applied the jack channel source for each step is set to the default value as configured in the settings.

What do you want to achieve?

To keep the MIDI channel set in the “work step”.

Are there any workarounds?

Re set the channel after applying the fill. Everytime. Alternatively the user can change the default MIDI channel each time before doing a fill for a specific channel.

Any links to related discussions?

Yes. But this is really inconvenient if the user have multiple external MIDI devices.
Another post

Any references to other products?


More Info

The manual on page 24 , suggest that the fill function keeps uses the “work step” settings Maybe it is a bug?