1.4 Firmware - MIDI fills revert back to Jack Channel 1 every time

Bug Description

When you use the new MIDI fills, every type (Bass, Snare, etc) along with every different genre selection you chose, makes a new fill revert track channel back to Jack Channel 1. The only types that aren’t affected by this seem to be Euclidean, Random, and Random+. Very cumbersome to have to go every single time to your “Sample Folder” and wind the encoder all the way down to USB Channel 1, for example, if you’re using USB Midi, to hear the midi. Track should keep its USB channel so you can quickly and effectively go through all the fills.

(In fact it would be great in general for the Play, if when you have “USB” selected as your ins/outs under MIDI settings, if somehow the channel selection would start for all tracks with the USB options, vs having to scroll past 16 Jack Channels every time to get to the USB channel).

Reproduction Steps

  1. Select track you want to “Fill”
  2. Hit “Fill” button.
  3. Select any Type, along with any Genre within that Type.
  4. Hit “Fill” to confirm selection.
  5. New fill is placed in track but its channel has reverted to Jack Channel 1.



Found in

Version 1.4

Hi @thegretalink , MIDI Channel and Note settings for MIDI Fills are available in Menu > Settings > Fill Config. Let us know if you have further questions. Cheers

1 Like

Oh that’s awesome, didn’t see that thank you!

1 Like

just mistakenly reported this, did not see. Thanks everyone for this awesome answer!

This topic was automatically closed after 7 days. New replies are no longer allowed.