Sample Pool folders disappear after restart and project load

Bug Description

I’m having an issue with the original Play where the sample pool folders disappear after restarting the device and loading a project.

The samples all still seem to be loaded and the project plays back correctly but the folders are all gone (if I go to samples > view sample pool in the menu I only see the option to add a folder), this makes selecting samples somewhat annoying and the fill functions no longer work because the samples aren’t associated with a folder anymore.

If I add a folder manually then all the samples get added to it and aren’t correctly separated by folder anymore, so the fill function still doesn’t work (for example adding a Bass folder doesn’t just contain bass samples, it contains everything in the project). Since there’s no way to move samples between folders (at least not on the device itself, I haven’t tried messing around with the contents on the SD card) this is kinda painful to continue projects across multiple sessions.

Reproduction Steps

  1. Load a sample pack with multiple folders into a project
  2. Work with the device normally, build up patterns etc…
  3. Save the project
  4. Turn the device off and on
  5. Load a different project
  6. Load the project that was saved in step 3
  7. Go to the menu > samples > view sample pool, see that no folders exist


This is reproducible all the time; however, it specifically seems to be caused by loading a sample pack. If I manually load folders one at a time, the folders get saved correctly even through a restart / loading other projects etc.

Found in

  • Version: 1.4.2
  • Build: 1297

Hi @blackbox Thank you for reaching out. We are sorry you’re experiencing issues while using our product. Unfortunately, we are unable to reproduce the issue ourselves. Would it be possible to receive a zip file from one of your projects, so we can investigate it? :slight_smile:

I’m having the same issue. Just got the Play, updated to 1.4. I load up a demo sample pack Chillhop. Fill a few tracks with kick, Snare, whatever. Save the project. Save the session. Click the button to turn of Play. Turn it back on. Select an empty track and try to fill with Kick, but tells me folder doesn’t exist. Even going to Samples/Folder there is nothing. All blank. I just got this thing 5 days ago.

Hi, sorry to hear you’re experiencing issues while using our product. Could you please tell me the version and build number of your device?

I got it working now. I am using Lexar 633x 128GB card which is UHC-I class A1. Per manual this is recommended type and class. No matter what I did in Windows 11 worked. Powering on the Play after saving session or project all the sample folders were gone. FOLDER part would just say ALL, but samples were still there. I booted up Ubuntu and formated the entire drive. Not just partitions. Seems that there is a small empty partition on the sd card that windows was creating or not deleting. After I formated with Ubuntu as MBR FAT32, I just copied my stuff over and just tested in play and it works.

Maybe Play should have Format Card like the cameras do. This was very annoying and ridiculous.


Yeah i remember having to attempt a couple things on Win 11 to format larger cards with FAT32. But i’m glad you got it working.

I actually like the suggestion of having a Formatting Option directly on the device, this could possibly alleviate such issues in the future. :heart:

1 Like

Apologies, haven’t had a chance to look into this in the last couple days. Here’s a link to a zip of one of the projects that is having the issue (I would upload it here but it tells me new users can’t attach files): Dropbox - Massive - Simplify your life

For what it’s worth, since others here mentioned the formatting of the SD card seemed to make a difference, I have since tried this on two different SD cards: the SanDisk Ultra 16GB UHS-I A1 that came with the Play (never reformatted, using the factory formatting) as well as a SanDisk Ultra 64GB microSDXC UHS-I (partitioned and formatted as MBR FAT32 using a Linux computer).

I’m using Linux to manage the files on the card if that somehow makes a difference, FYI.

While I notice that this second card doesn’t list class A1 as recommended by the manual (packaging only says UHS-I) on it, it seems to work a little better; this issue is still happening but I would say maybe 90% of the time instead of always.

1 Like

Hi @blackbox and @gegahrz, thank you for reporting this bug. I’m able to reproduce this issue with different SD cards now too.

We are sorry you’re experiencing issues while using our product. We will do our best to resolve it and notify you when it’s ready.

I am having the same issue. Using a SanDisk ImageMate PRO UHS-1 card, 256 GB and it happens regularly during a session (don’t have to power off for the bug to occur). Not sure exactly when the folders drop out, but usually I hit the sample knob and they are just gone. Using the Play + 1.0.1 firmware.

I’ve also been experiencing this on my new Play+, 1.0.1 firmware. SD card is the factory card, formatted to FAT32.

Hi, I’ve been experiencing the same issue. Tried to format the SD card with OSX gave me the same result. The only way I can use the Polyend Play is with the factory projects (which are working fine, here I can add a folder/pool and it stays even after turning the device off).

This has also happened to me after installing the new 1.01. firmware. Everything worked fine before.

Definitely having this same issues. I formatted two different cards and same issue. Kinda ruins your product for fast drum pattern building. Any word when this issue will be fixed makes it hard to use a machine that’s not functioning properly.

I’m also having the same issue. This is incredibly frustrating when you want to continue working on a song, except all of the sample folders are missing, which prevents you from using any of the Fill features because it cannot find the needed folder.

1 Like