Roll FX: RV, Rv sounds like simple R when placed on steps without a note

Bug Description

If a Rv or RV or Rn or RN or RR fx is placed on a step without a note, it only comes out as a ROLL (R), while in previous firmware it worked as expected.

Reproduction Steps

  1. insert a note wherever

  2. insert a roll fx (RV, Rv, RN, Rn or RR) one or more steps after

  3. listen, it only works as simple R



Found in

  • Version: (1.7.0)
  • Build: (123)

This is a big issue, all the projects I made with previous firmware sound different, worst in any case.


Hi @carlettogm , we’re sorry you’re having problems with new Tracker update. Unfortunately, we cannot reproduce the issue and we need your help. Please attach a project as an example of the issue, possibly it’s specific config setting or the way you use rolls (maybe with other FX?) that doesn’t work correctly. Thanks for your support!

so investigating this issue I found also another two :slight_smile:

  1. in 1.7 if RV or Rv are placed on a step without a note, they simply dont work, they only make a simple R, while in 1.6 and previous they worked right.

  2. There is a weird issue present on both 1.6 and 1.7 only for beat slice instruments (dont know if also “slice” has the same issue, you should check): RN, Rn and RR work in a wrong way, they do something but not what is expected. While they work right on one shot instruments. This happen also when FX is placed on a step with a note.

You can check this in the demo here: Dropbox - demo 2
On tracks 1&2 there is a one shot instrument, while on tracks3&4 there is a beat slice instrument.

  1. Saving multiple times the demo betwenn 1.6 and 1.7 I noticed something worong with project name: it always cut the first letter of the name of the project when opening in 1.7 a project made in 1.6, while opening on 1.6 a project saved in 1.7 it simply doesnt keep the name, it is blank.

Hi @carlettogm ,

[EDIT] Sorry, I understand now. RV and Rv have changed the behavior indeed. We will look into this and try to find a solution.

I’m afraid this is by design: each slice corresponds to a note on the keyboard (starting with C2 on top left pad) and the Roll feature will treat the slices as notes when it uses the Rn, RN and RR, as described in the FX overlay Description.

Opening a project which is saved in newer version on older firmware is not supported and might cause unexpected issues. We only support opening older projects on newer firmware versions: to avoid any issues in this case you have to follow the installation guide on the bottom of release notes.

Thanks for your support so far and we hope our answer helps you to find a solution to these issues.
Best regards

Please confirm if this is only about Rv and RV or you still experience issues with the other Rolls. This will help us understand and fix the issue fully. Thanks again.

Yes, I confirm in my experience this is only about Rv or RV

1 Like

Thank you for quick answer @carlettogm , I will update the title to reflect this, so other who run into this issue are better informed.

Same issue, very much looking forward to solving the problem

@here I’m happy to inform that this bug was fixed with the 1.8.0 firmware update. :slight_smile:
Thank you for helping us improve the Tracker!

This topic was automatically closed after 7 days. New replies are no longer allowed.