No option to select scale in global settings

I’m new to the Mini. Sorry if I overlooked something!

Bug Description

Looking at the Tracker Mini manual for the Random Note FX, it is implied that I can change the global scale and that the random notes will be picked from that scale.

In the global settings, I cannot see any option to change the scale. The Tracker+ manual mentions an option called pads scale.

Also, the Mini’s manual refers to the pads scale in several places, which I’m assuming is a mistake since the Mini has no pads.

Reproduction Steps

  1. Go to Config
  2. Go to Project Settings
  3. No scale option.

Is there a way to select a global scale for the Random Note FX on the Mini?

Occurrence

Always.

Found in

  • Version: 2.0
  • Build: 995

Attachments

From the Manual

image

Screenshot from the Mini

4 Likes

Not sure how Tracker+ and Mini projects can be fully compatible when this feature is completely missing.

Came here to ask the same thing. I was expecting a global scale in the mini settings, as I believe this was a thing in the original tracker and also tracker +, but appears to be missing on the Mini? I thought 2.0 firmware was to bring it in line with the Tracker +?!

I think in the Tracker OG, the Scale just sets what notes the pads relate to when targeting Instruments that aren’t Sliced. I don’t remember it enforcing a scale if you wanted to use the Jogwheel to increment or decrement the note value when targeting non-Sliced Instrument records.

Edit: Interesting, I jumped ahead and didn’t realize it also applied to the Random Note. Yeah, then it’s something the Mini should support.

Hi @matthieutc , thank you for all the detailed bug reports you’ve been submitting. It’s much appreciated, although we don’t always have time to respond fast. Sorry for late reply on this one. We took some time to discuss how to treat this, and although it’s obviously a bug for now, we wanted to deal with in in general terms of how to improve note input on the Mini. Anyway, we’ll let you know when we have a solution. Thanks for your patience and support!

Hi @miropoly :wave: No worries at all. Thanks for the reply.
These bug reports are a sign of appreciation, not dissatisfaction!