Upgrade from 1.7 to 1.7.1 instrument list plays sliced instrument instead of mapped sounds - no issues on 2nd update

Bug Description

updating to 1.7.1 from 1.7.0 adjusted my current project instrument list playback sounds to the concurrent slices from a sliced instrument - For some reason my sliced drum track (instrument line 4) replaces all the following instruments past that line with the slices from that instrument. The instruments are still labelled with their original sounds, but the actual playback pulls from the sliced instrument. Lines 1-3 on the instrument list are fine though.
Going back to 1.7.0 fixes this issue. Turning off the device for a few hours, then attempting to go back to 1.7.1 seemed to work fine the second time with no issues in the instrument list.

Reproduction Steps

  1. upgrade firmware from 1.7.0 to 1.7.1
  2. play song from beginning
  3. track 3 (labelled ‘HiHats’) will play slices from instrument line 4, rather than the mapped instruments 11 and 13
  4. attempting to ‘preview’ from the instrument list will also play the slices instead of the correct sounds


happened once

Found in

go to Config > Firmware page on your device and copy version / build numbers below



(I am unable to upload zip file as a new user, but the project .zip is attached to the link above!)

Hi @harryhood , sorry you had to experience this problem. Please follow installation guide as noted in release notes and you shouldn’t experience any problems. But of course let us know immediately if you do and we’ll try to help you. Thanks for your report

Hi @miropoly thanks for the fast reply. The firmware was initially installed per the release notes. I switched from 1.7.1 back to 1.7.0 and switched the device off for a while. When I came back I went back into Config > Firmware and updated back to 1.7.1 and could not reproduce the sliced instrument bug. Since the project was working fine I did not attempt to switch firmware’s after that.

I think what miropoly is referring to…
after updating firmware it says in the instructions to
open a ‘New Project’ first before doing anything else
like opening an existing project. This is necessary
for a clean update.

1 Like

Hi @harryhood , I’m sorry for misunderstanding, but your Reproduction Steps are different from our installation guide which requires creating a new project as @Akiko suggested in last comment.

Either way, I tried reproducing the issue with the project you shared and following your reproduction steps and failed. If you still run into the problem please let us know. In the meantime I will close this issue as not reproducible.

Thanks for your support!

Hey @miropoly and @Akiko - my bad on that and thank you for clarifying! I completely missed the opening new project step of the update, apologies I must have kept over reading that note in the instructions :sweat_smile:

Since this was essentially user error, would it make sense for me to delete this thread for tidying purposes? I’m not sure if that’s even possible but feel bad tagging this incorrectly as a bug. Appreciate both of your patience and understanding through my misunderstanding with this :pray:


Hi @harryhood , thanks for the kind words. I don’t think there is a need to delete it – it can stay as a reference if something similar comes up in the future. Thank you for reporting it and I’m happy we solved it :slight_smile: In anything else comes up, please don’t hesitate to let us know. Have fun tracking!

1 Like