Should the Play+ show up as a new audio interface?

Basicaly, what the title says.
I plug my play+ straight to my computer on-board usb in and, although I see it as a midi device, I don’t see it as an audio interface.
Is that normal?

It shows up automatically on most macs. Are you using windows or a hub? There are extra steps for windows I’ll try and find and post here either way. USB hubs are not supported and might not work either.

No, it is going straight to my computer on-board usb.
I have windows 11.

I can probably help you here since i have win 11 machine myself (and the Play+).
Are you trying to connect it to a DAW? If so which one?

I’m trying to connect it to ableton live and renoise (not at the same time).
I have another computer with win 10. The audio interface doesn’t show up.
Both computers find it as an audio device only through asio4all.

Yeah Windows is a bit funky and using Asio4All seems to be the best way to go about it.
This should work with Win11 as well though.

Shouldn’t it show up as a device?
Tracker mini, as I remember, used to show.
I’m not taking about agregate devices here…

Let me jump over to my Win 11 Machine and give it a go. I haven’t done so yet.
I remember the Mini not showing up for me, except when used via Asio4All.
I’ll report back in a bit.

1 Like

Alright so here are my findings, bare with me… since i have some explaining to do :laughing: :

As expected the Play+ does not show up for me when connected directly to a USB Port on the Mainboard.

This however is expected behaviour for my setup.

I have experienced this before with the Tracker Mini, as well as with the Original Play on that particular machine. Because for whatever reason all of those devices show up, as soon as i connect them through a USB Hub :laughing:

I have to this day not found out why this is happening and i am too lazy to change my running system as this does not impede my workflow, as i use an RME ADAT Interface mainly.

On a secondary Windows 11 Machine that i have, all of these devices show up when connected directly to a Mainboard USB Port, so this has definitely something to do with how that other Win 11 machine is setup or configured… or that the USB Config is just broken to a certain degree.
Microsoft doesn’t really offer any good way of resetting or debugging that, besides reinstalling the entire OS.

So, in your case, either try a different USB Port or try through a USB Hub if you got one. If you manage to connect it you should see it like this:




Now here is the next annoying part about Windows and Audio. If it doesn’t do ASIO or WASAPI, you are kinda fucked for the most part. In the Input Settings, the Device is recognized, with all the available channels:




However, when trying to access those in Ableton Live 11 for example, you get this:




Since Ableton still doesn’t support WASAPI, not all the channels are accessible. :frowning_face:

So do yourself a favor… and just use Asio4All, because then you’ll end up with this instead and a lot less headache :laughing: :

3 Likes

My findings are pretty the same.
If we all have the same findings, maybe polyend must provide us with a windows driver.
Relying on third party drivers is not an acceptable solution as it introduces latency, more points of failure etc.
What do you think about it?

1 Like

That one is a bit of a crappy two edged sword really. Technically you could also blame Ableton for not supporting the Windows Audio Session API (WASAPI), because then this wouldn’t be an issue.

Bitwig, Reaper, Studio One, Cubase support it for example. I personally use Bitwig.

Also just keep in mind /a small disclaimer: i’m just a community moderator voicing my opinion and do not speak for Polyend directly.

Based on my experiences with other devices from all sorts of manufacturers (instruments, interfaces, mixers etc)… this is a bit of a Windows Problem… and one of the main reasons why Asio4All is kind of ubiquitous when it comes to audio gear and the windows operating system.

Take Elektrons Overbridge for example …it took them years to refine Overbridge to the point that it actually works reliably for most users… and that is not an asio driver technically.

Steinberg and other Interface Manufactures to this day, have ASIO drivers that are not reliable across the board. With RME being the exception, but then again, RME works best on Windows and has its own set of problems under other operating systems :laughing:

I’ve had a Zoom LiveTrak L-20, that had specific ASIO Drivers, yet they didn’t work with Ableton because… some initialization issues… that weren’t an issue with other DAW’s but were a problem in Ableton. :man_shrugging:

I’m not sure Polyend at their size have the capacity or are willing to invest the time and funds into a possibly neverending development nightmare :laughing:

3 Likes

Also as an addendum, i have used Asio4All for years with Ableton, before switching to an RME based interface setup (and eventually moving away from Ableton).

I’ve never found its latency to stop me from making things. Especially since you can compensate the latency within Ableton.

By the way… for the unafraid - there are other ASIO solutions out there, like:

1 Like

Now polyend (I know that you are a moderator, and a pretty good one to my opinion) has two products that support USB audio. My opinion is that these issues should be fixed somehow. I tried renoise as well and it doesn’t work as expected. I don’t want to be crumpy but one of the selling points of plus was USB audio without “terms and conditions may apply on windows users”. Don’t get me wrong, I really really love their products and helped me make music (my yt channel is filled with play jams), but I feel that every play product comes with the hope of being constantly better machine and frankly, I constantly encounter usability issues.

This is very useful thanks.

Well first of all thank you :kissing_heart: and second: no worries, you are not acting or are not perceived as grumpy at all.

I totally understand your frustration, all i’m trying to explain is that this is a bit of a software/driver fuckery that has been a problem for many companies (from huge to small) for many years because of how shitty the Windows Operating System handles Audio.

I think the main issue is that people expect a Class Compliant USB Audio Interface to work flawlessly with Windows. That is actually NOT the case… it’s a combination of DAW, Hardware, Drivers. And that’s already a ton of variables where - excuse my language - the shit can hit the fan :laughing:

That being said… I mean… i’m not stopping you from creating a Draft wishes entry, in which you could request a Windows ASIO driver for Polyend Devices, so that we could have the lowest possible latency. hint hint :wink:

All i’m saying is:

  • Huge companies have tried and failed… and are still failing to provide ASIO drivers that work reliably
  • I’m not sure Polyend has the resources to create drivers for this.

I don’t think it is right to make a wish for things that don’t work as expected.
This is a moral issue I had when I made a simple suggestion for the note length parameter.
I suggested that the length of a note should be visible just like the piano roll and someone told me to make a wish for that so he doesn’t forget.
I think that the wishlist is for QoL things and crazy ideas that could make the products better, I didn’t want people wasting their votes on things that “pragmatically” are better.
These kind of things (the usb audio, the touchy pots etc) are things that destroy (for some) the features the product is advertised to do. To my opinion it a shame.

Thank you for your time.

That is exactly what the wishlist is for. And in my opinion an ASIO Driver for all the new USB Audio enabled devices, would most definitely constitute a Quality of Life improvement.

Honestly, i personally expected this to be the behaviour… but that stems from my experience with other hardware and manufacturers… and my personal knowledge/experience as a software developer.

I also understand that my expectations do not correlate with most users. And that is totally ok.
We are all entitled to our own expectations. :blush:

As it stands though, in its current state, it is absolutely possible to use the Mini and the Play+ as an Audio Interface. The caveat being that you require ASIO4ALL under Windows. Which by the way is also what Polyend suggests in the Play+ Manual ( see Page 194 and 196 ).

I don’t think your morals should weigh you down here, no? :blush:
My suggestion for you - and i mean this with the best of intentions :heart: - feel free to create wishes for things you’d like to be different, improvements, enhancements.

You never know how many other people might feel the same way unless you write them down.
And that is exactly what those wishes are for. It’s a bit of a court of opinion, that tells Polyend what people really desire from their products.

No need to thank me, happy to help and happy to talk about things :heart:

We only have 10 votes each, the “moral” issue emerges from the dilution of the things that are more important. I don’t want to spend my votes on things that don’t have gravitas (like the step length thingy).

Anyways, I’m not in a Karen mode right here and I don’t feel entitled to anything. I just shared my thoughts on the subject, in hopes to sparkle a productive conversation.
:slight_smile:

1 Like

and i hope we had that :blush: thank you for taking the time to talk with us and sharing your views on things :heart:

If it can help, I can confirm that on MAC if you use the USB3 port it works fine. (I have got an old early MAC).

So as I was guessing likely it doesn’t send audio data on old USB ports (2.1 etc.) maybe for this reason it does not work with camera connection kit.