Play+ USB Audio Not Synced/In Time with Ableton/Mac

I spent last night trying to suss out why the Play+ audio is delayed reaching Ableton Live. In this scenario I’m using an M1 Mac Studio Ultra on macOS Sonoma. Ableton 11 is the master sending sync to the Play+
There’s a few things I’ve been struggling with:

  1. Play+ won’t sync clock/transport via USB MIDI connection if using USB audio (it says no MIDI signal present). I’ve bypassed this by connecting it via DIN MIDI through my MIDI interface, and it seems to be working fine that way, but USB MIDI with USB audio doesn’t work.

  2. While they are now MIDI clock and transport synced, the Play+’s audio is very delayed, about a quarter note off from everything else in the project. I tried playing with latency and track delay in Ableton and can’t get it to sync up. It is following tempo and transport, but the audio streams are delayed in the session.

The session is running at 48k, and Play+ is part of an aggregate device that is working fine with other synths/devices in my studio. My Cranborne 500R8 is the master clock in the aggregate. I’m really excited about the USB audio feature for Play+, I hope I can get this working. Is this working for anybody else around here?

I’m not the most experienced user but if Play Plus is part of an aggregate device, then I think your session should be running at 44.1khz, as that’s the default sampling rate for Play. I didn’t think Play Plus will even do 48khz. My aggregate defaults to 44.1khz, so it’s odd to me that you can even have a sesh at 48khz with Play Plus in the aggregate setup, at all. I suggest you look at your sampling rates to begin with.

thanks…I tried 44.1 kHz and that did not work…but I’ll try going back to it now. My Motu M4 defaults to 48 K. I could not find the rate of the Play in the specs…nothing mentioned in web or in the manual, at least not in the specifications section, which is sparse.
But it seems to work great at 48K

It definitely will. Audio is coming through - no crackles or artefacts - it’s just delayed with the playing material in the project. If it was a sample rate mismatch the audio would be slowed down or not pass at all. It feels a lot like an audio driver problem since I haven’t been able to fix it in any traditional way yet. I’ll do a deeper dive tonight (and I’ve emailed Polyend support about it). I’ll create another aggregate device with only the Play+ and see where it gets me. USB audio is a nice thing to have, especially for the separated tracks, but it seems like it’s not quite there yet.

If I use USB to command the MIDI clock and transport and use the analog audio outputs it’s right on time.

I’ve had the same MIDI sync issues with Studio One on Windows 10 with asio4all. The workaround I’ve been using is to sync the midi, but not use the transport. I start recording in the DAW and then manually start the Play in time with the downbeat.

I’m such a dummy for not doing this in the first place lol. Works like a charm!! Just go full manual. :wink:

What I did notice while testing this out tonight:
Sample rate doesn’t matter, 48k/44.1k both work for transporting the USB audio.
Aggregate devices don’t matter either, as I have several devices rolled into my main aggregate but created a new one and only used the Play+ and my Mac’s speakers with no difference.
Triggering Live to start transport from the Play+ also ends up in an off-sync mess but it does trigger Live to start playing back. It starts out ok but about 3-4 measures in just loses sync completely (must use DIN cable, USB MIDI still didn’t work with USB audio).
I’ve had basically the same experience using the Play+ in Nuendo as well.
A clip I recorded in Live has silence for the first 0.1085 seconds/108ms. Adjusting the track delay or latency in Live doesn’t line that up however. I wonder if others have the same or comparable delay?

Same results with the settings below with USB-C connected directly to the Mac Studio. No word from support after sending a note a few days ago.

1 Like

If you have sent an email to support then you’re good. Optionally, you can create a Bug with the same information. Others having the same problem will be able to see it and follow any progress there.

This setting works best for me and is in sync.

1 Like

Related: Play Plus USB audio dies when switching projects in Ableton. In case someone here can contribute to that bug report.

You might be on to something - I’ll try this later today, thanks!

Update - this helped a great deal! Thanks for the heads up, I didn’t know that function existed in Live.

When I have Play as the only input device in Live and I delay the MIDI, I can get it to play in sync. It’s not perfect, but it does eventually get there (the first bar is wrong but it corrects itself). As part of an aggregate device it’s still not usable, and the MIDI In USB for Clock In and Transport In doesn’t work, still have to use a DIN cable.


I made various sync tests on MB Max RME FF UC:

  • USB Midi Song Mode
  • USB Midi Pattern Mode
  • Midi Jack Song Mode
  • Midi Jack Pattern Mode
  • 4 bars each
  • 2 cycle each

In the 2nd cycle it always loses sync. No matter which mode or jack. I have the impression that MIDI jack is slightly more stable. But everytime I hit the transport it changes the delay time. That would make it unusable for live sets as a 2nd sound source.

Any idea?