Play+ knob sensitivity: flickering between upper/lower parameter when a knob is held

When touching any knob, it flickers between states. Means I can’t use the double tap feature.

Play+, 1.01

Happened the same on the Play too.

People can have very different conductivity and capacitance. I guess I’m at one of the extremes.

I can’t upload an mp4 on android using the icon, so here’s a Google photos video link.

1 Like

Curious if you had other people do the same thing for you to verify it’s actually related to differences in people’s fingers and not say something wrong with the unit you have specifically.

1 Like

Duplicate reports?

Yes!

Hi, yes, the issue happened with one other person the same as me though not as intensely in a different location. Three other people were fine. It also worked fine for me and the other with whom the fault occured in yet another location.

I’m based in Thailand and have measured the power at a stable 220V (grounded as I say), tested in air-conditioned environments.

I’m sure your engineering team are “on it”. Is the issue is reproducible at your end? I wonder if there is an equivalent to a measurement hysteresis which might address the issue.

Thanks!

@alxzndr Just to be sure. I want to cross out one possibility.
There is also a chance, that the flickering encoders may be touching the metal chassis of the Play+.
Could you try to move them up and down and left/right to bend them a little (carefully :wink: ).
Let me know if there is any improvement.

1 Like

Hi Borsuk,
No difference - it’s occurring on all knobs too, just as on the two prior Play models which passed through my hands. Closed source and all that, but I’m curious if there’s a hysteresis effect could be tuned on these presumably capacitive knobs.

I had the same issue. Switching the Polyend adapter to an Apple adapter fixed the problem for me.

Best,

Thijs

I want to mention this happened to me twice on my Play+ and I found that if I “sweep” my hands over all of the knobs, just touching not pushing or anything, as if I were trying to “touch trigger” all of them at once, it fixed the issue immediately. I have not encountered it since.

I hope this can help

Hi @here Thanks for your patience. We are doing our best to resolve this bug. We will notify you as soon as the firmware containing a fix for this issue is ready. :slight_smile:

2 Likes

Yeah I had it the other night skipping between menus, I tried to get to start a new project and I had to do a hard reset in the end. It still didn’t help and I had to time it (with luck) to start a new project. I thought I would have to send it back. I hope and update will fix it. The only thing so can add that might give a clue to what caused it for me, was that I was live recording parameters and adding some long reverbs and delays to them.