Play+ and Ableton problems

Hi there!

Just received my Polyend Play+ and I’m trying to connect it to Ableton on my Macbook Pro without success.

It comes with a USB cable but since I only have usb-c ports I am using a Type-C to Type-C 100W cable to connect it and it connects and powers on nicely.

Then I load a pack, put some steps and hit play but nothing sounds on Ableton.

I am trying to do this setting the Play as input device instead of my sound interface, and setting the pre-record button on an audio track.

What am I doing wrong?

Edit: Just realized I should put the mini jack to stereo jack adapter on the output of the Play and then connect it to the inputs on the back of my Motu Ultralite MK5 through 2 jack mono cables right?

Thanks in advance!

There’s something in the manual about creating an aggregate device. Not sure if that would resolve. I’ve not tried to connect to the Mac yet.

1 Like

(EDIT: sorry, I thought this question was about MIDI but it isn’t.)

1 Like

I don’t have a Macbook Pro, but I do have Macbook Air and Mini. Both M1 on latest macOS. I used the USB-C to USB-C cable that came with my iPhone. Plugged into both computers and Ableton saw the Play and audio came out. I did have to go into Live>Settings>Audio>Input Config and activate the channels. No aggregate device creation was needed.

Also, Mac Mini, had to go directly into Mac vs a dock I have, yet the manual states, no hubs.


What do you mean by activate the channels?

I think I am doing it right and I am reading the manual but there is no guide for connecting it to Ableton precisely.

Thanks guys :pray:t2:

After you goto the path I mentioned, ensure the channels here are activated. Orange means activated. If you’ve already done this, ignore me :slight_smile:

Didn’t do this so I will try later and will say, thanks man!

Crossing my fingers for you. Also, depending on the version of Live you have, you can only activate X number of channels. I don’t recall what those are but Ableton’s site has the scoop.

1 Like

Anyway, the sound should be coming out just having the Play+ connected through USB right?

I am a bit confused with the mini jack to stereo jack adapter provided.

Yes, audio should come over USB. I’ve never used the mini jack. Maybe one of your friends is over and wants to listen?

Ok, I tried a lot of things after reading the manual.

If I just plug the Play+ on its wall charger and put the headphones on the out, it sounds.
If I plug the Play+ directly to the Macbook Pro it doesn’t sound.

I attached a screenshot showing that I created an aggregated device (the one called Play+) as the manual states and selected my Motu interface since it is plugged to my monitors.
Then I go into Ableton and I select Play+ as input interface instead of Motu and there is no sound coming in.

I’m very frustrated right now and don’t know what more to do T__T

I don’t use Ableton but let’s see if this helps or my advice is so embarrassing that another user feels compelled to reply with actual Ableton wisdom. :slight_smile:

  1. Take the Play+ add a 4x kick or any sampler and press Play. Keep it running. Plug your headset to ensure that it is producing audio. Don’t connect the Play+ to the audio interface or to any speakers. This is only to ensure that you are sending USB audio to your Mac.
  2. Connect the Play+ to your Mac using the USB cable that came with the Play+. You should see it as a device in Ableton, and you should see 28 mono channels / 14 stereo.
  3. In that Audio 1 track you have, click “Audio from”. The 2 first Play channels should be the Master left/right. Select it. The Play+ audio should be seen right there in the track’s meter. If you see the meter moving, you’re good.
  4. If Ableton is properly configured with your audio interface and your speakers, the Play+ sound should make it to the speakers.

Once you have the Master audio working, you can improve your setup by mapping the separate audio outputs for each Play+ audio track + the outputs for effects.

1 Like

You might also need to setup configure speakers/headphones here under ‘configure speakers’ (see where my arrow is pointing). Harmony H224 is my audio interface outputting to my headphones. Probably the UltraLite-mk5 in your case.

I got this working with FL studio today, and every channel needed setting up manually to get it to work similar to @icaria36’s instructions. The one that outputs everything is shown as “Input 1 - Input 2” for me and the easiest thing is try to setup that one, in my case I set it up in the mixer, and then when that is working I setup “Input 3 - Input 4” and so on … all the way down to “Input 27 - Input 28”. The channels that are shown as reserved in the manual are actually incorrect and used for synths 2 and 3. So all 3 get their own channel.

1 Like

Here I don’t use Ableton at all but I setup the first set of inputs and this works. You can see how I called the first set ‘play mix’ then set it up under ext in, and turned on monitor in, and then below it in Ext out is my audio interface. You should hear the main mix when press playing just by having the usb of the play+ connected to your computer with similar settings when done correctly. Then can configure all the others one by one.

1 Like

Hi Radfara.

Thanks for the help to begin with.
I tried everything as you told me but maybe I’m doing something wrong here because I get no sound at all.

I attach here a screenshot showing almost every window and don’t know if everything is set properly.

Questions I have:
Is it normal that there is no sound coming through when plugging my headphones to the mini jack out on the Play+ while it is connected through USB-C cable to the Macbook?

Because the aggregated device makes sound on the laptop when I set the speakers and when a beat is being played on the Play+, it shows the input signal coming through under the laptop sound options as shown here:

I tried a lot of different cables by the way (always directly to the laptop, no hubs).

Kind regards.

That is very strange about the headphones not working when connected via USB-C, I am using a m1 mac mini and that works for me. I did it a bunch of times when settings it up already that way just to test if the sound from the device was working when I was setting up the software to just confirm the audio was working in general. It you plug it into a USB-C power adapter instead does the audio come back? It points to some issue there, but I have no idea why it might do that.

The bottom screenshot where you circled the volume level in red, I actually still have my audio output there setup to my audio interface and not the aggregate device. I was unable to get the play to output to my headphones connected to my audio interface by selecting the aggregate device for some reason (I don’t normally use speakers). If that actually worked, I would view that as causing an issue at least if I was wanting to control which channels I was hearing in fl studio or ableton live and not always hear all of them. So also have it purposely not selected as the audio output on the mac so I can get per channel control. Otherwise I have the aggregated device setup to the input same as you in ableton live.

Showing this again (screenshot below), with two more inputs setup this time because you didn’t show that. Everything else seems ok to me. The manual doesn’t mention this part at all so, it’s the easiest part to overlook. Every set of two inputs (the channels) needs to be setup in the mixer similar to this. If it’s working correctly at least 50% correctly you should see the volume meters move around when hitting the play button on the play+ and having appropriate patterns setup. Nothing will move for instance if I mute the first two sample channels or have nothing there on the play+ itself because then
there is no output. If the meters are not moving those are probably not setup correctly in the mixer or elsewhere. If the meters are moving, but you don’t hear sound then the outputs are not setup correctly. Mine is setup here to monitor the 1st and 2nd sample channels (mixer 4 and 5), and the 3rd mixer I have currently off, but could turn it back on to monitor everything at once.

Yesterday I used the Play with an external battery and the charger that came included and worked great with headphones, but the moment I plug the device on the laptop with any USB-C cable, it seems the headphones jack doesn’t output sound.

This is driving me crazy because I don’t know if its because the cable (I tried 5 cables), the unit or something in the configuration.

Also it seems so strange to me that the sound options on mac shows the input sound coming through but it can’t be heard anywhere.

I’m using the latest MacOS software on a M3 Max Macbook Pro through the thunderbolt 4 port.

As an experiment if you haven’t try plugging into a USB A port or a hub plugged into a USB A port and not the thunderbolt even though that should work too. Going to try my thunderbolt directly and see what happens.

I have several USB hubs in use at once including some where a cable goes from the Mini, into a monitor hub, and the monitor USB goes into another unpowered hub, and I’m actually connected to that and it works. I have another powered hub that just goes straight into the mac, that one when connected it shows the play device as being 0 input and 0 output. When I changed to the other hub it shows the correct numbers that’s the one that works for me.

OK jackpot, headphones into the play+ also don’t work when connected directly to my thunderbolt. So there is some odd issue there. Probably my USB A recommendations will help. There is also some other strangeness when connected to thunderbolt that I’m looking into now and will post when I figure it out.

Edit: I don’t know for certain, but I’m also going to assume a USB hub probably needs to be USB 3 or greater to work, but maybe that isn’t needed.

The other issue with the thunderbolt is mysteriously the master output channel (the entire mix first channel). It shows the green bar moving to indicate audio, but it’s VERY tiny and I hear nothing. Maybe some way to boost it but I don’t know how and it shouldn’t be that low, so I not even going to attempt it.
The second two channels that go with samples however do work just fine with appropriate volume levels! Seems it just makes sense to use normal usb and not thunderbolt for it.

edit: not sure what happened there as I got the master output not working properly via usb A cable too after that, but fixed it by deleting the aggregate device and creating it again.