"Insert SD Card"

Hi, I’m having trouble with my Poland play. I wanted to update to v1.3 and after doing all the necessary steps the device doesn’t recognize SD Card anymore. I get a message on the screen “Insert SD Card” So far I tried formatting it ( fat32) I also downloaded original content and firmware v1.1 same thing . My PC recognizes the SD Card but poly play just doesn’t. I also tried resetting device multiple times and end up with the same result. Any suggestions ?

Hi Tomas and welcome to our little corner of the internet!

I have two suggestions for you:

  • Have you tried the official recommendations from the manual, in case there is an issue with firmware updates? Direct Link: Polyend Play - Manual
  • If that doesn’t help, do you have another SD Card that you could try?

Let us know how it went! :crossed_fingers:


Hi Sandroid !

Was able to do the update with Polyend Tool. Managed to find a spare SD card so formatted it to Fat32 and copied original SD Content and it worked ! Although it still can’t recognize the original SD Card that came with PPlay.

Cheers for the advice !

Glad it worked out :partying_face:

Under what OS (Windows/OSX/Linux) are you trying to format the old card? Maybe i can give you some additional advice to get it working again. I did a lot of trial and error under Windows when it came to sd cards :sweat_smile:

I’m using Win 10 machine.

So… At first I did format the original SD card using the default Windows tool.
When that didn’t work I tried different SD card which is like 238GB card and for some reason default Windows formatting tool would only let me to format it to exFAT or NTFS.
I downloaded Guiformat application which was able to do the work. I also tried using the same tool to format the original SD card, but that didn’t do the trick.
I remember I already had a similar problem when was doing the version 1.1 update. That time formatting the card did work. Well, the lesson I learned is only update is using a Polyend Tool, the less you mess with SD card the better I guess :slight_smile:

You are in luck! :laughing:
I’ve went through the same ordeal with bigger cards.
Here’s what worked for me. Maybe (hopefully) it will work for you as well:

  • Format the Card with the default Windows Formatter as exFAT
  • Download the GUI version of fat32format here: Ridgecrop Consultants Ltd
    (by clicking on the picture)
  • Convert/Format the card once more in that utility

Hope this helps. :muscle:

1 Like

Update !
It happened again “Insert SD Card” !!!
After transferring some sample libraries that I own to SD card. I’m really confused now…:confused:
I wish It would be possible to transfer files using Polyend Tool instead.

Will give it a try ! Cheers !

hmm… what are you using to transfer the files? Are you using the provided usb sd card adapter?


Ok, well let’s see first what happens when you format the cards, the way i mentioned.

I personally have started using a different card reader early on because i’ve had my card get corrupted a couple times with the provided reader.

Since then i’ve also started to religiously unmount the card / device properly the windows-way via the “Safely remove” functionality (see: Safely remove hardware in Windows - Microsoft Support).

I went through the formatting process again and when loading with the original SD card content it works fine.
I always use Eject (safely remove) option before disconnecting USB memory devices (a lesson I learned years ago the hard way :smiley: )
I will try to play around some more tomorrow with different card reader. I’m sure I have it somewhere… Will drop an update then.
Thanks for the help ! Have a nice evening ! :slight_smile:

1 Like

Hey Sandroid and everyone who will read this.

I think I’m on to something. First is that the other card reader that I have doesn’t work properly so I had no choice and played around with the original one some more.
So the thing that worked for me is after ejecting external drive (using “Safely Remove” function) waiting for a minute or so.
I think I did take it out to quickly before and it would screw with the SD card. I did it a couple times just to double check and it worked every time so yeah… :slight_smile:
I still haven’t tried it with the original SD card though, but I have a feeling it should work…:slight_smile: :thinking:

1 Like

Windows and removable media has always been a bit of a pain. :person_shrugging:
But i’m glad you got it sorted out or found a way that works for you :blush:

1 Like

Last week I was an avid reader of this topic because I messed with one… no, with two SD cards and I would get the “Insert SD card” message with both, when both had worked perfectly well just a day before.

Today both work again. It wasn’t because of any of the reasons shared above. I tried everything, even waiting a minute before removing the ejected USB stick. :slight_smile: I didn’t like to use Windows to solve this, or to install a freeware utility just for this, or user 3 different card readers… Too much black magic for what is just some metals and file formats playing together,

So this is what worked for me in the end:

  1. Make sure that the SD card is partitioned as “MBR”. Turns out there are other options that are fine for a PC but not for the Play. This information is not obvious or very visible, and it’s the problem I had in one of the cards.
  2. Make sure that there is only one partition. Or if you really need to have more than one, make sure that the partition that is going to be read first is the one with the Play folders. The other SD card had a small “free space” partition at the beginning, the PC would just skip it, but the Play would get stuck with it and not find the Play folders.
  3. With the 2 steps above completed, formatting the SD Card to FAT is the easiest step.

My mistake was to think that “logically” a SD card problem with the Windows FAT formatting would be better solved in Windows. Actually, the problem was that the Windows apps wanted to make my life easy, by hiding these important details. Then I tried the Disks app in Ubuntu (a preinstalled utility) which shows you transparently what the SD card has, and allows you to format the entire drive (and not just one partition) just as transparently.

Once I figured this out, I fixed both SD cards in the time it gets to download and copy the Play files.

I am trying to use Tracker Mini with 256 GB Sandisk Extreme. This is formatted in FAT32 with MBR. I copied all the factory content downloaded from Polyend support into the SD card. However the Tracker mini wouldnt load - it is stuck on the “Please insert SD Card” page. Please help

Hey @sforsuresh welcome to the community! :partying_face:

i’ve only used up to 128 GB so far, but those worked and are well past the range of normal FAT32 usage :laughing: . So i see no reason why 256 GB shouldn’t work.

How did you format the card?

Hi @sforsuresh , I have moved your post to this topic. See "Insert SD Card" - #15 by icaria36, maybe it helps.

Thanks for the response @Sandroid !
Using diskpart, I converted to MBR. I formatted the SD Card with HPUSBDisk.exe Utility - this is formatted in FAT32. The SD card has only one volume - it is very similar to the original SD card that came with the Tracker. I copied all the factory content for Tracker mini downloaded from Polyend support page.

The Original SD card in fact got corrupted (there were 100s of workspace folder automatically created and the tracker mini wouldn’t go to the past the Opening last pattern page). I followed the similar process as above and it worked. It is just not working for the 256GB card.

On a side note, 128 would have been adequate for me, but unfortunately, have now spent money on the 256GB card!

Gotcha. Give the following a try and let’s see how that works for you. This has been the one reliable way of formatting big cards for me (when having to format on a Windows machine):

1 Like