Freezing while previewing samples

Bug Description

Play sometimes freezes while previewing samples. Unit is completely frozen and not usable, a restart is needed.

Reproduction Steps

  1. begin track and preview samples in sample packs
  2. often play will freeze when trying to preview samples



Found in

  • Version: 1.4.1
  • Build: 1099



Unable to reproduce. I will keep trying.

So originally I just loaded a sample pack and began making a track before trying to preview more samples in other packs which is when the bug presented itself. On the next project I started I began by previewing samples in various packs before loading anything and the play froze at least 6 times while trying to load individual folders from packs

Just tried again and it froze. Took a few. The sounds are still playing but nothing is moving. Used the steps you described.


Yeah audio was unaffected but everything on screen was frozen and requires a hard restart

I’ve been noticing this since 1.4.0 and also experience it on 1.4.1. My first attempt at capturing this on video was not fruitful. I finally got it this morning. Around 3m30s.

1 Like

This happens to be as well, has been for a while. I’m not able to reproduce it on specific samples, therefore I suspect this might be a memory leak or something – it happens usually after having previewed many samples.

Yep that is precisely what happened to me!

@here Thank you for reporting this. However, we still can’t reproduce it. I will let you know if there is any progress on this.

One thing I’ve noticed is that it can happen when previewing a longer sample and then trying to preview a different one before the long sample has finished

@bcrane780 Could you attach the specific globalsettings file that is in the Projects Folder? It will give us some insight into the circumstances of the freezing.

Are these the settings you’re looking for?

I mean the globalsettings file that is in the Projects Folder on your SD card :slight_smile:

uh apparently that file type is not supported in this forum is there a better place i can try sending you a copy of the file?

try zipping it, or email to

2 Likes (130 Bytes)

ah that did it thank you


Thank you! :slight_smile:

@anon80935742 Please do! It will help us a lot.
@here We will do our best to fix this issue, and notify you when it’s ready.

1 Like

Hello everyone, I have the same problem. With own samples and also with the polyend packages. I already tried the globelsettings file and it doesn’t work. The device just freezes. Is there any news about this?

I can’t really use the device at all at the moment. :frowning:

The problem came up again and again, but now nothing works after listening to it 1-2 times.

1 Like