Encoder skips values if not perfectly centered at power-on

First please read How to report bugs

  • when filling this template, remove all text in Italic including this paragraph
  • submit the bug report by fully completing the template below

Bug Description

Encoder calibration is inaccurate if encoder is not in centered position at startup, causing the encoder to not register movement (especially when changing to opposite direction). I have been able to repeat this on two Tracker+ units.

Reproduction Steps

  1. Move encoder slightly toward one side or the other of encoder indentation while in a set position.
  2. Power up the device.
  3. For most extreme results, start up with encoder between indentions. This was not necessary in either unit i tried.
  4. It is most easily repeatable when changing knob directions


depending how off center of the indentation is, the more often it will not register changes.

Found in

anywhere the encoder is used. visually obvious in pattern editor

  • Version: 1.01
  • Build: 955


simply drag and drop to upload or paste links to:
photos, short videos, and project folder (.zip format only)

May i ask you to fill in your current firmware and build number. Also if you can, please provide a video of the behaviour so that we can see what you mean. I’m personally a bit confused what you mean by ideal position :laughing:

So you are deliberately positioning the encoder in between the raster/indentations?
Why would anyone even want it, in that position during a rest?

  • took out the word “sample” from report.

  • the ideal position for an encoder is in the exact center of the indent :grimacing:

  • i won’t be providing a video. since the encoder isn’t marked, the benefit of that is not in line with the effort.

  • no one would do that intentionally except a programmer trying to recreate the bug. the title of that section is “reproduction steps.” if you read the steps, i am clear that the encoder only needs to be nudged slightly off center. it doesn’t need to be engaged that far to happen, but that’s how to get the error to repeat 100% of the time. since the issue seems like an intermittent hardware issue with the encoder without investigating further, i figured i’d help out and save Polyend some returns.

  • The bug won’t impact me since i know i have to set the encoder to a perfectly aligned position at startup :joy_cat: but it was pretty alarming until i knew the cause of the dead spot in the enoder. :person_facepalming:

I’ve just tried this on the T+ and OG Tracker by positioning the encoder in between indentations and then powering on the device.

It is true that the first time you attempt to increment or decrement something. it will just skip doing so. but afterwards it seems to work without issues again? Is this the behaviour you are describing? I don’t seem to be able to cause any further skips this way.

I wasn’t aware i was being condescending, just answering Sandroid’s question “Why would anyone even want it, in that position during a rest?” The answer is that they are instructions on how to repeat the bug reliably.

1 Like

If it only happened on the first turn it would be no big deal. The problem is that it persists after the first turn. It is most easily repeatable when changing knob directions (will edit that into my initial report).

The problem varies from start up to start up depending how off center the knob is

1 Like

Just a quicky - words can be easily misconstrued.

Please refrain from any unnecessary squabbles, we are just trying to get as much detail for this bug report as possible.

If my feelings aren’t hurt, neither should yours.
And there is no need for further “he said / she said” either :wink: :heart: :hugs:

If i may - do you notice this everywhere, where you attempt to change values?
Or is there a particular screen where you notice this more?
I’ve tested it so far only on the pattern screen, to see if scrolling still works as it should.

My apologies to all for my comment earlier. Good luck with the solve!

  • I just confirmed it with the Master, Sample and Performance areas. What happens is it skips the first value after changing directions on the knob (if its turned on with the encoder with the indent)

  • I also want to reiterate that I discovered this in normal use and the steps I listed are to make it easily repeatable. The knob doesn’t always end up perfectly in the indent after use or perfectly off center for that matter, if that makes sense.

  • i can’t see the code, but my guess is that there’s an internal calibration process for the encoder that happens at startup that gets corrupted when the knobs a little off during power on.

  • For users currently experiencing or bothered by this problem, i now just make sure the knob is set to the dead center of an indent right before powering it on.

1 Like

I’ve been trying to reproduce this, but I’m getting the same results as @Sandroid, both with the OG and the +. I’m getting that first initial jump, but thereafter the encoder functions as normal.
Curiously I don’t feel any wiggle room on the indentation. What you describe as the “ideal position”, it feels impossible not to have it in that position when the encoder is not being used.

I’ve been able to reproduce this, it’s easier to see in the master volume section. On power up the volume is for example -10.23 db, turn knob clockwise 1 notch and it’s -9.59 db, turn knob counterclockwise 1 notch and it stays at -9.59 db, while it should be -10.23 db. Turn knob counterclockwise another notch and then it changes to -9.59 db. Turning the knob clockwise gives the same effect. It doesn’t skip a value, but it keeps a value for a step to long.

1 Like
  • changed “ideal position” to “centered” since this is causing confusion.

  • I haven’t tried it on my OG, only two Tracker+'s. It tends to happen after direction changes (going from a clockwise to counterclockwise turn).

  • I’m not sure this has anything to do with “wiggle room”, but i think the mass of having a large metal knob, with the addition to having it rest on the new internal plastic brace might be making it a little easier to accidentally have the knob remain outside of the indent after normal a turn.

  • Spin your knob a few times, you’ll see that some of the time it does not settle in the indent.

thanks for explaining this better, than i had. i can see how the way i explained things might add some confusion. going to edit the report a little to be more clear.

i was thinking of the encoder values (x/number of indents) and not the values shown on the screen.

Got it. I can confirm that I can reproduce this scenario with the Master Volume when purposely booting holding the encoder off of the indent. However, if while the Tracker is turned off I randomly spin the encoder and then don’t touch it, and then turn on the Tracker, 10/10 times it’s working normally.

Your explanation was clear and a big thanks for taking all the time you did you report this bug. What helped with @hannibalpeck post was an easy step by step to reproduce it.

As I posted above, I can indeed reproduce this at the extremes meaning I’m booting the tracker holding the encoder between 2 indents.
I’ve tried 10 random spins of the encoder while it’s off and then I boot it up, and it just seems my encoder falls in this “centered” position everytime.

no problem, love the tracker and happy to help. i haven’t done a count of how many times it happens, but i did come across the problem naturally on both trackers (putting a second one through its paces for a product exchange).

one thing i’d like to note is that the behavior described by me and hannibal is the most extreme/reproducable case. When it happens naturally its more intermittent problem since the knob doesn’t tend to fall between idents naturally. It misses a turn a percentage of the time and presents differently each time depending on where it as startup.

if you happen test again, look for more random skips under similar conditions, if that makes sense.

Hi @cathyh Thank you for reporting this bug. We are sorry you’re experiencing issues while using the Tracker+. We will do our best to resolve it and notify you when it’s ready. :slight_smile:

1 Like

Thank you for this. Got my t+ yesterday and I had the same issue, in my case the encoder was completely wonky all the time and would skip values constantly, but powering it on while centered on the indent seems to fix it for now.

My encoder does not reliably stop at an indent when I stop spinning it, is it supposed to just click into the next step?