Can't download from Palettes - "Network Error"

I have been trying to download a purchased pack from Palettes and I get repeated failures. Get part way through and then the download stops with “Network Error”. Anyone else having issues?

I’ve tried both Chrome and Firefox. Another weird things is if I retry the download starts at the begin again; if it resumed from where it died I’d be able to eventually complete it.

Update: its take up to seven attempts but I have finally got the ones below 100MB to download. Still struggling with Harmonic Horizons which is about 220MB. Giving up after about a dozen attempts; will try tomorrow.

Just a quick question to determine some things:
Are you trying to download all at the same time or one after another?

I have noticed this behaviour from the server as soon as i tried to download multiple things at the same time from Once i download only one item at a time, it seems to work.

One at a time. And specifically one (Harmonic Horizons) that has now failed more than a dozen times.

I managed to finally complete the download by using curl from the command line and having it resume from the last point. Not sre why the browsers couldn’t do this right. Downloaded it in four chunks but it is all done now. What a PITA.

Anyone else have trouble with broken download links to some of the palettes on the polyend site? i purchased three of them but one of them just refuses to download and im not sure why

Hey @bcrane780 , i’ve merged your post with this existing topic regarding this subject.
I’ve got a few quick questions, that might help to determine what the root cause may be on the server:

  • does this happen when you try to download multiple files at once?
  • does it happen if you only download one file at a time?
  • does the browser not offer a way to resume the download?

I also just noticed there is a third related topic, which i will post here:

@Mitch, i’ll tag you here since this seems to be a valid concern at this point regarding these failed downloads.

Looks to me from the outside like there are either some server issues or a misconfiguration that is causing this.

Don’t know if this could help, but the times that I’ve had issues downloading content from Polyend, it gets fixed if I switch on a VPN with a European location.

So i havent had any issues with downloading multiple at a time or even having a download fail halfway through. just one specific palette wont even begin to download, every time i click on it i get half a second of the browser loading or acknowledging i have clicked download but the download never even starts

I tried downloading it in a different browser and it told me that the particular palette couldnt be downloaded securely

Which one specifically? This way i could give it a try as well.

it was the dark garage pack

Thanks for the info. I’ve just tried this myself. The download doesn’t start for me either.
While testing i’ve noticed that a couple other packs don’t start a download either.

I’ll report this and hopefully this can be fixed soon.


Thanks! glad im not going crazy

You are definitely not :hugs:

I’m having the same issues and I’m already crazy :upside_down_face:

Hey you all, sorry for this problem! Web devs are aware of the issue and made some changes that should fix the issue. Can someone that had the problem please confirm they can now download the packs?

Issue still persists for me. I’ll record a video later and share it privately as i don’t want to expose any file locations to the packs. I’ll send it to you directly @Mitch .

unfortunately still can’t download the dark garage pack

Sorry again, the web devs have made more changes and are still working on the issue but this should be resolved for most people now.

Can confirm the downloads that didn’t work, seem to work now. :partying_face:

1 Like