Audio Preview of samples from SD card doesn't play via USB Audio

Bug Description

When the Tracker Mini is used for USB Audio, the previews for samples that have not been loaded yet are never played. Loaded samples that are part of the instruments list however work as expected (they are output to the mix on 1/2 and to the first track on 3/4).

Reproduction Steps

  1. Connect the Mini via USB and listen for Tracker Input 1/2 in your DAW or equivalent program.
  2. Got to Sample Loader
  3. Try and preview any sample

Occurrence

Always

Found in

  • Version: 1.0.0
  • Build: [please update]

Attachments

1 Like

You have to hold down the preview button as you scroll. Or press it on every sample to hear that sample.

Sorry, preview does not work on my unit until a sample has been loaded. I currently own 2 OG Polyend Trackers and have owned another previously. The Mini currently does not act in the same way as my OG Trackers.

I mean, it wouldn’t be insane to have minor differences between the functionality of the OG and the Mini? This might be one of those instances? I don’t have an OG but there might be something wrong with your Mini then? You definitely should be able to preview stuff before loading it in using the “Preview” button in the Sample Loader menu. Should work for stuff on the SD as well as samples already loaded into your project.

And that is why I posted here. It should preview from the SD card as you stated as the text above the Preview button lights up, but it does not. Hoping there is a known bug or a fix on the way. The button used for this works perfectly in all other applications.

Also tried other SD cards from my other Trackers to verify it’s not an SD card issue. Same result with each card.

So, it is only over USB that the Preview button is not working. Seems to be a bug for sure. When using headphones it works as it should. Super odd.

Hey @TSM , i’ve updated your initial post so it adheres to our Bug Reporting Template and renamed the topic, so it includes some more details.

I’ve added some details as well, since i have encountered this myself and found out what the issue is exactly.

When connecting the Mini via USB, it will try become an Audio Interface, exposing the 24 Channels that it offers. The Sample Loader Audio Preview is currently always routed to Tracker Channel 1/2. There you will always be able to hear the preview.

Now if you don’t listen to those channels, then you don’t get any preview.

On the one hand, it makes sense that it behaves this way, hence i’m not certain this is a bug… on the other hand, it would be nice that the Sample Preview could be heard across all Channels, so this strange behaviour doesn’t occur.

when connected via USB the unit should not preview the loaded samples on a different channel than the samples being previewed off of the SD card. The is what it seems to be currently doing. I have 1/2 playing through in Logic and only the loaded samples are audible, while the samples on the SD card are not. I have also now routed all audio inputs into Logic and the SD card sounds do not preview on any of the audio channels. Preview works perfectly when using the audio line out.So it still seems to be a bug…

Ah sorry, you are correct.

I’ve just tested this in Bitwig. Regardless of routing, the preview will not play. Doesn’t matter if the final output is routed through the Mini or not. I’ve also noticed that the preview of any loaded sample will always play through 1/2 and 3/4.

I also retested with AUM on iOS and the behaviour is actually the same, i must have been mistaken then. Sorry for the confusion :pray:

I’ve updated the description so to not confuse anyone :laughing:

1 Like

Hi all @here, thanks for pointing this out. Preview of samples from SD card has still not been implemented fully: you might have also noticed it’s still in mono when previewed through Line Out (not USB Audio). We plan to implement this in the upcoming updates properly, including fixing this ‘bug’ which has been waiting for stereo implementation. We’ll let you know when it’s done. Thanks for detailed report and patience.

1 Like

P.s. I will update title to reflect the problem more exactly, so others can find the info.

2 Likes

@here I’m glad to inform you that this bug was fixed in the Tracker Mini 1.1 firmware update :slight_smile: Let us know if you’re happy with the solution, and thanks again for your support! :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.