Alternate Sample Loading / Fill assignment Logic

It would be nice to have the option of choosing the folders for the fill to use, rather than it only looking in a specific folder.

What is the problem?

For example, I am trying to do a ‘kick fill’ and it responds ‘Kick not found’.
When I look in the sample pool I have a ton of kicks within the folder called ‘kick’.
(I guess it’s looking for a folder called ‘kicks’)

Or maybe I want to use the ‘Chords’ fill on my piano samples. If there is no synth folder, clicking Fill button could present a dialogue box: "Hey, which folder should I use to create this fill?’ rather than just a ‘not found’ error.

Even better, as @ambivalence suggests:

  • when user loads/creates some folder (with any name), the device just asks what kind of sample it is (bass, synth etc)

What do you want to achieve?

It would be a nice quality of life improvement, to be able to choose a folder instead of having to follow the rigid naming convention.

Are there any workarounds?

The workarounds would be to properly place all of your samples in appropriately named folders, but who has the organizational skills for that?? not me. I’m importing samples from various sources and many of them use different naming conventions.

Any links to related discussions?

Any references to other products?


Hey @choogaface, i’ve added the proper post structure for you wish and moved your text accordingly. Please fill out the remaining parts and adapt/improve as you see fit. :blush:

1 Like

hell yes.

moreover, I’d suggest these two things:

  • when user loads/creates some folder (with any name), the device just asks what kind of sample it is (bass, synth etc)
  • when user wants to use fills, he can choose whatever folder he/she wants (specific bass folder, for example) or a whole type as we have now

because having, let’s say, all the synths in a single folder maybe nonsense in many scenarios. what you want to use some specific synths for fills, but not all of them? what I you want to use RND sample by folder too, but also want to have specific a set of synths? the way it works now reminds me my of first python scripts with primitive if-then-else constructions and hardcoded logic which is okay for the beginner maybe, but not okay for the production software/hardware, in my humble opinion.

I suggest you change the wish for something like that, because I’m done with wishes and there’s another thread for the thing you ask, even though it wasn’t approved and made ready for voting since the 18th of May:

feel free to bump and like it.

1 Like

Hey @choogaface , please read @ambivalence wish and let me know if the two are overlapping. Then we can close one of these two :blush:

Yeah they are basically the same wish. You can close mine if there can only be one, that’s fine. :+1:t3:

@Sandroid I’d say that wish is different, because it aimed on folders that have many samples of different types in the same folder. There’re many sample library releases that are not organized well and making them work exclusively for Play is a lot of work, considering the fact there’s no convention for this and it cannot be automated with scripts. A simple json-like file with the interpretation rules right on the device would work perfectly. It does solve the fills problem too, but only partially making all “kick_releasename.wav” interpreted as kick even there’s no “kick” folder in the project.

This wish with the last edit (@choogaface :clap:) proposes an additional question during the importing process: what kind of samples this folder provides? That would allow having multiple folders for the same kind of samples. It opens the possibility to use the RND sample by folder with precise needs. Supposedly, it would also allow using different fills with different folders of the same type.

1 Like

so do we keep both? or try to come up with one wish that incorporates the aspects of both? :thinking:

I see the feature in this wish as absolutely essential should-be-there-by-default thing while the other one is just about helpful user-friendly UI that alleviates manual sorting on SD card. There are sample packs with all the files placed in the same folder and without that feature we still need to doublecheck everything by hand before uploading.

So. I’d prefer to keep both, if devs plan to make it a good sequencer. It lacks a lot already speaking about sample editing features and other «limitations», so at least it should be comfy to use its basic features. But in case there are no plans to put many efforts into Play and we absolutely need to choose, I’d vote for this one, of course.

As for the one wish that includes both, I guess it’s better to keep them separated, because straightforward wishes are easier to grasp/vote/implement.

Decided to keep em both. :blush:
Good luck to both of ya :kissing_closed_eyes:


@Sandroid maybe we should rename this one though? For something like «Ability to use any folder with the fills feature and determine sample folder by tag instead of exact names».

That’s quite a mouthful :laughing: I’ll try and shorten it.

@here Thanks for your wish. It’s now ready for voting :slight_smile:

1 Like