Weird behavior with synths on Play+

I received the Play+ on Tuesday and the the synths do sound great btw, but i’m having a weird time with the operation, I don’t know if it’s the pick and place workflow, but start a new project and leave the default synths, synth 1 is selected by default, I select the 1st midi track, change to synth 3, start playing on the 4x8 keyboard and it’s synth 1 presets playing, but i’ve not got synth 1 selected on midi track 1?

Also getting this weird issue with what seems like a stuck note? while playing on the 4x8 keyboard too, when you move to a higher octave, it jumps back to the default octave page, then when you play 2 or three notes together a high root note will start sounding, anyone else seen this? I can’t say I noticed this before the patch editor firmware, as I wasn’t paying too much attention.

could you share a project that exhibits that behaviour? would probably make it easier to understand the issue. and if reproducable we can change this topic into an actual bug report.

Sure can, but really it’s with any new project, not a specific project.
I just tried it again starting a new project and same behavior, i’ll see if I can make a video.

1 Like

I think I’ve experienced something similar on my OG Play, so it may not be something for the + alone. And I’ve also experienced this across projects. It’s not something that I feel like I’ve been stuck with, so a restart might have solved it for me when I ran into it (it has turned into one of those bugs that I just work around without too much thought). I just received my + yesterday (yay!) and will try to be pay more attention to this if it occurs again.

Okay so i’ve attached the saved project, no pattern data, just the default init patches changed to other patches.

Without selecting a step, open keyboard view, you can play any of the synths and preset no problem.

Click view, to come out of keyboard view, select midi track 1, regardless of which synth you select, it will only play the patch of the last synth used before you selected the midi track, this is the same for other midi tracks.

I noticed you also have to select a step on the track before it lets you select a synth for that track too, so if you create a step on step 1 assign it synth 1 then deactivate the step, then select the track again it will show as synth 1, but go back to keyboard view and it will playback the synth that was used without any tracks selected and changing synths makes no difference, it’s really confusing me? As I would have expected if I select a track and assign it a synth it should play that synth for that track, right?

Another thing I noticed, you can pick and place different synths on different steps, but if you select the track and change the synth, it will change the synth for all active steps too, it doesn’t do this if you only change the patch of the synth though, so something to be aware of.

synth test.zip (3.8 KB)

Yeah thats strange, well when it has happened on the synth parts, it’s either a stuck note playing or when I start to play multiple notes on the keyboard a high root note will play over it, if I change patch it sometimes stops then I can start playing on the keyboard again, it seems to be intermittent.

If you find a weird behavior, it is better to submit it as a Bug , otherwise it’s easy to forget about this topic in the middle of all discussions.

I think I covered the strange synth keyboard bug here - or at least some of it. Please comment there if that is the case: Pad keyboard for samples/synths with play+ not working properly when about to do record mode (possibly play too)

Also would be good to know if there seems to be some others issues around that, that were not accounted for in that bug report.

2 Likes