Unit Freezes when opening old project file from Play

Bug Description

When trying to open an existing project that was created and transferred from my Play. All LEDs turn red and Opening Project status bar does not move. Power button does not work only disconnecting USB power will turn off the unit.

Reproduction Steps

  1. Click encoder
  2. Select File
  3. Select Open Project
  4. Select project file ‘Midi Template’, click open

Occurrence

bug is reproducible happens every time I try to open the project file.

Found in

Version: 1.0.1 beta
Build: 1376

Attachments

simply drag and drop to upload or paste links to:
photos, short videos, and project folder (.zip format only)

well that looks ominous :laughing:

2 Likes

Hi @baywolf88 , sorry you’re experiencing this issue and thanks for your detailed bug report. Unfortunately, I cannot reproduce it with the same build #1376 here. The red LEDs might indicate it’s “out of memory” type of problem and when I open your project I see it might be the case as Sample Pool is at max 99%.

Nevertheless, I’m sorry you cannot open your project, this should never happen. We’ll look into this and hopefully have a solution for you soon. Please let us know if you manage to open it, possibly it depends about the current state: for example if you start from new project and then try opening yours? Thanks again for your support!

FWIW opening a new project and then opening Midi Template project does open successfully. However I’m still having some issues opening projects after having Midi Template project open successfully.

I removed unused samples and saved the project, then tried to open another projects and the Play froze again, but without the all Red LEDS

Hi @baywolf88 , what kind of issues? The same one as described here? Could you please share the project(s) that causes the issues? We cannot reproduce similar the problem here. Thanks for you support

@baywolf88 are you still experiencing this issue? We haven’t been able to reproduce it. Please let us know and thanks for your support

Hi, I am facing the same behaviour with a project created with my play+. When I hit Open, it starts loading for a few seconds and then the pads turn red and the unit gets frozen. I tried loading this project while no previous project was loaded, but I still get those red pads.
Do you think that removing some samples from the project directory might help?

Version: 1.0.1
Build: 1405

Follow up: I have removed some samples from the samples folder of the project and I have been able to load the project again (and use the “Delete Unused Samples” function)! :man_surfing:

1 Like

Hi @djenzar , thanks for your message. Please attach the project and we can investigate further. We believe this might be related with loading samples which exceed 32 characters in filename, but we can’t say for certain if the issue you’re having is the same or different. Thanks for your support.

Hi @miropoly, thank you, I’ll check if I have a backup of the original project… In the meantime, I’m 95% sure that the project had samples with more than 32 chars. I’ll get back to you anyway. Best

1 Like

Hi @miropoly, I don’t have any backup of the original project, sorry, but I can confirm that the samples loaded have names longer than 32 chars!

1 Like

Unfortunately I also have problems with some projects on the Play Plus. And, as pointed out, it looks as if especially samples with long names cause problems.
I now have multiple projects where samples changed after reloading the project.
This is really annoying :frowning_face:

In general the Plus seems a lot less stable than the original Play. With the same SD card navigating samples feels much slower and when you load complete folders the Plus sometimes freezes. I think I never had a freeze on the original Play.

Hi @JimP4nsen , thanks for your comment. I’m sorry you’re having issues with Plus. Please attach the projects and we can investigate further.

This sounds like a differnt issue than what’s discussed here. Please consider logging a separate Bug and attach the projects which you’re having issues with.

Finally, this seems like yet another problem. Please log a Bug with the problematic folders/samples attached and we’ll try to investigate what could be the problem.

Thanks for your support

I’m sorry, the error might have been on my side.
A couple of days ago I noticed that I was still using the beta firmware and the official one contained a lot more fixes.
I didn’t have a crash since then! Sorry for the confusion. Will keep you updated if I notice anything.

@JimP4nsen thanks for the update. Let us know if further issues occur. I will close this one for now :slight_smile: Cheers

@here wooops, too fast :slight_smile: I see now that others had issues here also. If everyone could let me know if their issues where solved that would be very helpful. We haven’t been able to reproduce this case since. Thanks!

@JimP4nsen @baywolf88 do you have any update on your issues reported here? Are you still experiencing them? Please let us know, thank you.

No further issues. Its been several months since I’ve seen that mean red rectangle.

1 Like

I‘m sorry, but I can‘t find a way to reproduce it consistently. Sometimes you load older projects and they play just fine. Sometimes they get stuck during loading, sometimes they load but some samples are replaced by garbage noise.
It might have to do with having projects that use most of the memory, but as said, I haven’t found a combination of project loads that can consistently reproduce some of the errors.
I’m using Firmware 1.0.1 build 1405