Tracker SD card corrupted after 1.8 update

Bug Description

Tracker SD card was corrupted soon after 1.8 update.

Reproduction Steps

  1. I followed the update instructions including opening a new project.
  2. I played some of the existing projects on the SD card.
  3. Then I created a new project with a single sample playing (from a sample pack).
  4. When I went to the list of projects to open a different one I saw a lot of corrupted file names. See photo attached.


I don’t know if the bug is reproducible. I’m going to try restore a backup.

Found in

  • Version: 1.8.0
  • Build: 840


When I ran disk check on my Mac I saw

% sudo fsck_msdos /dev/rdisk2s1
** /dev/rdisk2s1 (NO WRITE)
** Phase 1 - Preparing FAT
** Phase 2 - Checking Directories
/MyProjects/(???1i.n?? starts with cluster out of range (496977500)
Remove? no
/MyProjects/3JI?Ȑ?f.=P? starts with cluster out of range (600824261)
Truncate? no

When I run a diff -r against a backup…

Pattern files in projects that I didn’t open are different
Binary files /Volumes/TRKR231221/MyProjects/cas test midi 60 patt/patterns/pattern_92.mtp and /Users/ger/Documents/Tracker/Backups/20240318/MyProjects/cas test midi 60 patt/patterns/pattern_92.mtp differ

There’s garbage file names on the disk:
Only in /Volumes/TRKR231221/MyProjects: òkâ[wá(.ü+Ñ
Only in /Volumes/TRKR231221/MyProjects: o„¦)w.â}é
Only in /Volumes/TRKR231221/MyProjects: q;q3ek.âb~
Only in /Volumes/TRKR231221/MyProjects: rhŒs’)Éô.58f
Only in /Volumes/TRKR231221/MyProjects: r¥"Ð3CV.

1 Like

That’s crazy!
I had a similar experience this weekend…
…with the difference that my SD-Card (the original which came with the tracker) was unusable altogether.
Neither the tracker nor my Mac could read it anymore. It would not show up in the finder anymore.
Disk utilities app couldn’t find it.
All my projects (samples and recordings) so far are gone.
The card has not been moved inbetween. It was in the tracker, worked the day before, next day it’s dead.

Well, on the positive side I don’t have to think about all the unfinished pieces of music anymore that I was collecting since I got the unit.

I think I have enough weird tracker adventures for now. Starting with a unit, that froze every twenty minutes, a radio that never worked and now a destroyed SD-card for no apparent reason than being in the tracker over night.

I did not connect it to the update first, but now reading this.

I wonder if I should take out my 64GB card that I replaced it with to not risk another damaged card?

The SD-Card that came with my tracker died on day 1 when I was transferring files onto it from my Mac - same symptoms as yours - luckily I didn’t lose any compositions. Maybe some bad cards got shipped. The card I bought to replace it has so far been rock solid.

Upgrading to 1.8 for me was fine, but I have had sd card corruption like this maybe 2 or 3 times just generally from reading and writing to the sd card in windows, im not really sure if it’s an issue with the tracker specifically, but it’s happened a lot in comparison to for example my camera’s sd card where i don’t think ive ever had it corrupt

if there’s any way to reduce the chances of this happening just in general it would be pretty great for me, i’ve lost projects and had to spend a couple hours repopulating all my samples a few times now (but again, upgrading for 1.8 for me was fine, but in general this has happened, with the strange characters for names and everything)

I used the original card for some month now. It died with 1.8
I wanted to show a friend how cool the Tracker is and he witnessed how the machine asked to insert a card while it was in there. This demonstration proved pretty much the opposite…

I took out the card, put in the Mac, Mac couldn’t find it either, no chance of reviving.

I take out the other card now and go back to the previous firmware… just to be safe.

I reformatted the card & restored my backup.

Before ejecting

ger@Gers-MBP-2 TRKR231221 % sudo fsck_msdos /dev/rdisk2s1                                
** /dev/rdisk2s1 (NO WRITE)
** Phase 1 - Preparing FAT
** Phase 2 - Checking Directories
** Phase 3 - Checking for Orphan Clusters
5576 files, 12870528 KiB free (1608816 clusters)


I put the card into the tracker (still running 1.8.0) turned it on. Waited 30s and turned it off without doing anything. Brought the SD card back to computer to restore the rest of the backup and ran fsck first thing. It now reports “Free space in FSInfo block (1608802) not correct (1608837)”.

ger@Gers-MBP-2 ~ % cd /Volumes/TRKR231221                                       
ger@Gers-MBP-2 TRKR231221 % sudo fsck_msdos /dev/rdisk2s1
** /dev/rdisk2s1 (NO WRITE)
** Phase 1 - Preparing FAT
** Phase 2 - Checking Directories
** Phase 3 - Checking for Orphan Clusters
Free space in FSInfo block (1608802) not correct (1608837)
Fix? no
5573 files, 12870696 KiB free (1608837 clusters)


I downgraded to 1.7.1. Did nothing else. Brought the SD back to the computer. Reran fsck which “Found 331 orphaned clusters”.

ger@Gers-MBP-2 ~ % sudo fsck_msdos /dev/rdisk2s1
** /dev/rdisk2s1 (NO WRITE)
** Phase 1 - Preparing FAT
** Phase 2 - Checking Directories
** Phase 3 - Checking for Orphan Clusters
Found orphan cluster(s)
Fix? no
Found 331 orphaned clusters
Free space in FSInfo block (1614491) not correct (1613144)
Fix? no
5637 files, 12905152 KiB free (1613144 clusters)

I compared everything on the SD card to the backup. The differences:

  • .fseventsd/fseventsd-uuid changed
  • a file changed (I assume the open project)
  • a new file Workspace/patterns/patternsMetadata

I fixed the orphan clusters and put the SD back in the tracker (now 1.7.1). Turned it on, then off and brought the SD card back to the computer. I saw “Free space in FSInfo block (1618250) not correct (1618251)” but no orphaned clusters.

Firmware 1.8 surrealist adventures.

Everything was fine, until this morning.

Samples gone,

Plus 23 recordings freshly made last night with the new 133 second recording limit.

OK, I got so wound up with this sudden data loss that in pure caveman anger I whipped out the SanDisk 256 Ultra micro sd card while the Tracker was switched on.

I was greeted with please insert sd card.

So I did.

Now the data is back, all projects loading.

This is most bizarre. I also cleaned the gold contacts on the SD Card.

1.8 firmware seems to freak out a few systems here and there.

1 Like

You damn lucky!
It did not work for me… unfortunately.
It just doesn’t recognise the card as a card anymore (the original 16GB).

1 Like

Mate, I feel for you there. I was in a mad panic,
I never used the original card from the beginning because it was too small in capacity.

Something is definitely fishy going on with 1.8.

Wishing you a swift data recovery mate. :+1:

Hi @here, Thank you for reporting this bug. We are sorry you’re experiencing issues with the 1.8.0 firmware. We will do our best to resolve it and notify you when it’s ready.

1 Like