Tracker Mini 2.0 synths won’t stop sounding

I recently got the tracker mini and updated to 2.0 first thing. On a couple of occasions the synths engine seems to bug out and won’t stop sounding even after pressing stop “play button” and won’t even stop even if adding a different instrument on the same track that should choke it?

I have had to restart the mini and after that it would solve it. I haven’t tried to add an effect that sets the volume to zero because that might fix it but I’m pretty sure it’s a bug since it won’t even stop after stopping the song from playing.

Anyone else had this?

3 Likes

Hey @bobo.meijer, welcome to Backstage! :partying_face:

Do you have a project where this issue is reproducable?
If so, could you share it with us? It would help the developers a lot.

I’ve also had this error with certain sounds.

I know what project I had I happen on but haven’t tried to reproduce since I still haven’t spent much time with the tracker :grin:

But I will try and I can definitely share the projects. Let me know how.

Common nominator might be that I was trying to figure out how to use the “fill” feature on the synths like high pass filter or something else that might have triggered this.

Just zip the project folder up from your sd card and upload it here. If it’s too big use Google Drive / Dropbox / OneDrive or equivalent :pray:

I had this issue too, although it hasn’t occurred for a while. I got around it by temporarily setting the polyphony to 0 before returning it to the original value. If that helps.

5 Likes

Are you sending multiple notes at the same time? I’ve had hanging issues with multiple notes (from both the new synth engines and external gear). Mainly it happens to me during live record, usually when playing on step 1 - lots of messages get sent if you start playing slightly early.

I think it happened to me for a different reason. One of the projects only has one note for that synth engine but had effects and the other project had two notes but only once for every pattern. Could be related but don’t think so.

I’m on holiday right now and will se if I’m able to upload the projects from my iPad. :smiling_face:

Yes, I was playing with this issue today. I ended up stopping it by sending a different instrument note on the track as it did not respond to sending an !off

1 Like

I think that worked for me to but when changing patterns that last note would keep playing and when stopping the song all together the synth would keep on sounding. Until a full restart och the tracker mini. Did you experience the same?

Mine stops when I stop the song/pattern, but keeps going when the pattern changes unless I do the workaround I mentioned. Maybe the quirks are synth/patch specific? I’m using the Cobwebs patch on the WTFM synth.

Does adding a FAD, OFF or CUT help?

I encountered this issue again today while trying to make a video on how to use an iPad as a keyboard for the mini. Don’t think that was the reason but maybe that I added a bunch of notes in very fast. So I have this issue now recorded on video but it’s a bit to make to post now because I need to pack for my flight home from vacation :smiling_face:

Anyway it didn’t help to add an “OFF” note and when stopping the playback the sound was still on. I had to power off and on the device to get it back to normal.

2 Likes

by setting the polyphony of the synth to zero, this cuts the sound and avoids a restart.:wink:

2 Likes

Cool! So will it solve it when setting the polyphony back to 1 after the sound has been cut?

by setting to 1, everything returns to normal…

1 Like

Hopefully the devs read this and it can help to fix the bug :smiling_face:

I have opened a bug report for it. For me it mostly happens when I use note repeat in perform mode.

Also thanks for the moving voices to 0 to avoid restart :slight_smile:

An fx that controls voice allocation could be a quick and dirty work around.

1 Like