Track to keep using the same synth voice after using the fill function

Bug Description

describe the issue you encountered and what is the correct behavior which you expect

After using any fill other than Euclidean / Random/ Random+ on a synth track, the track loses association with a synth and has to be reassigned

Reproduction Steps

Create a new project

2 Go to Synth mode and enter some steps/notes

3 Press play to hear the notes

4 Select the track

5 (optional) Press Sample/Folder encoder and select a synth voice to change from default/init

6 Press Fill and choose any Type other than Euclidean / Random / Random+

7 Press Fill again to apply it - audio stops

8 Press Sample/Folder encoder and see that Device has switched to Jack Channel 1

9 You can then manually change the Device back to synth to hear the fill pattern

  1. write down minimum number of exact steps which reproduce the issue

Occurrence

*bug is reproducible - always

Found in

go to Config > Firmware page on your device and copy version / build numbers below

  • Version: 1.0.1
  • Build: [example 345]
1 Like

I haven’t tested this, but the description looks more like a Bug than a Wishlist request? Does this still happen with the new firmware released yesterday?

About the “the track looses association”, what do you mean? Do the current steps associated to a synth change to something else? Does the currently selected synth change if you create new steps? There is no " track association" with synths, midi, or samples, that’s why I’m asking.

I think this may be caused by selecting an unsupported fill type

Here’s the workflow to reproduce:

Create a new project

Go to Synth mode and enter some steps/notes
Press play to hear the notes
Select the track
(optional) Press Sample/Folder encoder and select a synth voice to change from default/init
Press Fill and choose any Type other than Euclidean / Random / Random+
Press Fill again to apply it - audio stops
Press Sample/Folder encoder and see that Device has switched to Jack Channel 1
You can then manually change the Device back to synth to hear the fill pattern

Thank you for your detailed description. I suggest we move this topic to Bug and you adapt your description to the bug template there. What do you think?/

Sure!

1 Like

Done! Please edit the description with the Bug template.

Hello @pandigital Thanks for your report, I’m sorry you’re having issues. This particular case is by current product design: You can change what it should pick in the Settings.
image

  1. Press encoder > Scroll down to Settings and press encoder.
  2. Scroll down to Fill Config and press encoder.
  3. Scroll down to the bottom and set the Synth / Bass Channel.

You can reference more info from pages 114 and onwards in the user manual.
image

Please let us know if you need any more assistance. :slight_smile:

2 Likes

I’m sorry for the extra work @pandigital , I didn’t know this either…

This topic was automatically closed after 7 days. New replies are no longer allowed.