Recording and then editing a sample using Tracker Mini built-in microphone causes unit to stop producing sound

Bug Description

The way I’ve been using the built-in microphone sample recorder causes the audio engine to crash 100% of the time. The only way to get the unit to make sound again is to reboot. I’m not sure if all of the steps below are required to cause the crash, but I’m confident that these steps will always crash the unit.

Reproduction Steps

  1. New Project
  2. Sample Recorder : Mic : Turn up gain
  3. Record a 4 second sample
  4. Adjust both the start and end points by about half a second
  5. Hit save, auto name, then save and load
  6. Switch to sample editor and adjust the start and end by a little bit
  7. Effect : Crop : Apply
  8. Effect : Normalizer : Apply
  9. Switch to Sample Playback

Result: Sample Playback screen is blank. Hold down “instrument” and for some reason #51 midi channel 1 is selected. Select instrument 1 (your sample) and it will display. However, you won’t be able to preview it. In fact, the entire audio engine has crapped out. Nothing you do (pattern playback, preview samples in the sample loader) will produce sound. You are obligated to reboot the Mini to get it to produce sounds again.


  • bug is reproducible always

Found in

  • Firmware 1.0.0
  • Build 492

Hi @canton, thank you for reporting this bug. We are sorry you’re experiencing issues while using our product. Unfortunately, we are unable to reproduce the issue ourselves and could use a bit more detail.

Would it be possible to get a video of what you’re doing? A phone or tablet video is already sufficient. Because by following your reproduction steps I’m unable to crash or freeze my mini. After step 9, the sampled recording opens and is also dropped into the first instrument slot of the Mini.

Could you also try the “Reset config” option from the Firmware menu for us, and go through your reproduction steps again?

Hi Hans,

I did try resetting the config at some point, but still experienced the problem. I’m sorry my steps aren’t reproducible. If nobody else is reporting anything like this then maybe it was a fluke with my unit or my methods.

Regrettably I can’t record a video now, I’ve just returned the unit to the vendor. This bug was manageable, but I couldn’t tolerate the inconsistent ability to use phones/devices as MIDI controllers over USB. Since I require use of the real-time note recording feature, MIDI support was a necessity. However the only device that worked was an iPad that had a USB-C port. Despite trying every possible cable/adapter combination I could think of, I couldn’t get an older iPhone (lighting port) or android pixel 8 (USB port) to ever recognize the Tracker Mini as a USB destination.

I’m hoping that Polyend eventually produces an update to the original tracker (which I also have) with support for stereo samples. Really the original tracker is perfect for me, except for the lack of stereo samples.

Hi @canton , thanks for your comments. I’m sorry you’re having issues with your setup. But unfortunately, we officially don’t support iPads, iPhones or Android devices. We only support latest Windows and macOS operating systems with Polyend devices.

Thanks for the kind words. We are always happy to hear happy customers. We don’t want to give you false promises or hope, so unfortunately I have to say that original Tracker will not have support for stereo samples (in this format) due to technical and performance limitations.

Hope this helps.