Polyend Play+ USB Audio, Windows, and asio4all

I’ve managed to get USB audio working in Studio One on Windows 10 with the ASIO4ALL aggregator and it seems to work pretty well. That said, Ideally I’d like to sync the playback tempo with the DAW. It’s pretty straightforward to do this with DIN MIDI but I the USB MIDI interface doesn’t seem to show up. Is this a side-effect of using ASIO4ALL or am I missing something?


Follow-up: When I say I have this working, well perhaps I jumped the gun. Syncing with DIN MIDI delays the start and >kinda< stays in sync, although behind a bit. Also, attempting to record a whole performance this evening (2 attempts) made it about 2 minutes in and the audio became overwhelmed with glitchy distortion (not intentionally). Increasing the asio4all buffer size didn’t seem to make any difference.

I’d be curious if anyone else has tried this?

Question! What CPU do you have? Intel or AMD?

I’m asking because:

This seems to affect the Play+ as well.

Similar to my experience except I’m using Cubase. Cubase has a monitor window to show disk/cpu level and it was all at minimal (as expected), but the type of “glitchy distortion”, as you describe it is similar to the sound of when my cpu or disk usage is peaking due to overwhelming my system with

EDIT’ I’ll note that I started to get those glitches about 25 minutes into a jam, but that was just playing back the audio between 14 stereo tracks. I didn’t attempt to record anything. I’ll give that a go during the weekend and report back with results.

1 Like

Intel i5-12600k, so it should be good?

Yeah, I didn’t try just monitoring or just monitoring the master while recording the multitrack. I’ll have another attempt this weekend.

After trying a number of things today I have been unable to record a whole session. It starts out good but around 2-3 minutes in the audio fades into garble and then fades back to clear.

I’ve also been looking for other options than asio4all and there doesn’t seem to be any that support multiple input channels. Sigh.

Also, I confirmed it isn’t a CPU issue - watching the performance when it happens and I have plenty of overhead.

Another update: I managed to record a whole session today. The “secret sauce” was to make sure the buffer size was the same for each interface in the aggregate asio4all config. Also, the midi usb interface is strangely now visible, so I don’t need a separate DIN cable.

So far I could happily interface the Audio through USB without a glitch on my Ipad Pro with both Mono and Separate Tracks on AUM but the Live 11 on my Win 10 is just painful… I’m not relying on ASIO4ALL at all , I mean I did test it but not enough, really wish Ableton could straight their programming for a WASAPI compatibility and Multi Midi channel Routing… 2024 still no trace… Will test on my Macbook but I think it may just not work straight out of the box…

I have the same issue. Every 3 minutes i get 12 seconds of distorted audio.
Using asio4all with all devices set to the same buffer size.
I am on win10 with AMD Ryzen 5 4500U processor
Using a usbc-usbc cable.