Polyend Play Midi Setup in Reaper

I am trying to setup my Polyend Play to sequence some virtual synths on my DAW (Reaper) but I am struggling to get it to work. I thought I’d ask here about my setup on the Play side before I see if it’s something with my DAW.

For the play I have enabled every MIDI setting to USB instead of internal or through one of the jacks.
Notes in channel is set to Omni.

Reaper recognizes the Play as it shows up as a device within it’s settings, but after enabling midi inputs and outputs to the play I am not able to register any notes on a vst with the Plays keyboard view. When I try to play a sequence the Play also tells me that it is not receiving any clock from the USB either even when I have pressed play within Reaper.

I’m sure I must have missed something I’m just not sure what. I’ve set up midi keyboards and even my microfreaks sequencer pretty easily before but this is a bit different it seems.

Hey @jwnamon , welcome to the community! :partying_face:

I personally use Bitwig and don’t have Reaper, but what i can help you with, is ensure that you have the right settings configured on your Play. :blush:
So if something doesn’t work, you should only have to worry about Reaper after this.

If i understand you correctly you want to do the following:

  • Send Tempo/Clock and Transport (Start/Stop) from your DAW to the Play.
  • Send MIDI from the Play to your DAW so you can trigger/sequence notes for a VST.

Assuming i understood you correctly, here’s what you gotta do on the Play.

Your general midi settings on the Play should look like this:

And then when sequencing the midi tracks, make sure that your notes are being sent to the proper channel. You can change that when touching the Sample-Knob and changing the Channel to whatever value you require:

That should be it.

:information_source: Small tip if you are on Windows:
I noticed that sometimes it does not recognize Midi Notes immediately.
Restarting the Play once before a session, usually does the trick.
Not sure if it’s a Windows USB Issue.

Hey thanks you so much for your help.

I used your settings and I’m at least getting somewhere but I still have a couple issues. Reaper is finally registering the Play and is clearly receiving midi messages from it as I can see it receiving signal when I press keys on the side keyboard when on the correct channel. The play also starts the sequence when I hit play in Reaper and is on tempo. If I hit record on Reaper I can record my midi sequence into reaper and play it back.

Here’s what I am missing:
I can’t hear the sounds live/pre recording. With other midi controllers I can press notes on them and hear my vst, I was hoping to do the same with the Plays keyboard view. Currently I can only hear my sequence once I have recorded the midi data into reaper, making the process of creating and editing sequences for vst’s way more tedious than I’d want it to be.

I would also like to be able to start the sequence with the Play’s play button instead of having to use reapers but I can see how this might not be possible unless the play is sending the clock rather than Reaper.

So miraculously it is all working now after a simple restart. The only thing I’d still like is to be able to start sequencing with the play button on the play instead of reaper.

So I’ve found in reaper where I can map midi CC’s to transport functions and I am able to map the play button on the Play to Reapers Play button, but when I press play to pause the sequence it just restarts the sequence. This happens when I’ve mapped the Play button to both the Play or Play/Stop actions in Reaper.

Glad to hear you got it “almost” working. :blush:
Hoping someone with some Reaper experience can help you get the last problems sorted out. :muscle:

Then you need to configure the Play settings accordingly:

  • Clock in - Internal
  • Transport In - Off
  • Clock out (USB and/or Jack, whatever you are using)
  • Transport out (USB and/or Jack, whatever you are using)

And then you need to configure your DAW to use the received clock and transport instead of its own. Usually DAWs have specific functions about this, no need to mess with MIDI CC data.

I’m not a Reaper user either, but have you checked in their manual “23.8 REAPER as Client to MIDI Sequencer Software”? It seems that you need to right-click the play button and select the Play there.