Polyend Mini cannot stream audio over USB

When connecting the Polyend Tracker Mini to my PC, it is not available as any sort of audio device. When I open Ableton Lite 11, it is also not available as a device to stream audio over USB. I have followed Polyend’s directions as layed out in the manual directly.

Reproduction Steps

  1. Connect Polyend Tracker Mini to PC using USB cable
  2. Turn on Polyend Tracker Mini
  3. Open Ableton Live
  4. Go to preferences, audio, and open devices
  5. Polyend Tracker Mini is unavailable to select as a device.


bug is reproducible always

Found in

go to Config > Firmware page on your device and copy version / build numbers below

  • Version: [1.0.0]
  • Build: [492]

Hi @carlinplumb , sorry you’re experiencing issues and thanks for your report. Before we can help, we’d like to know which version of Windows (?) are you using and what kind of USB port are you connecting to? Are you using an USB hub? Have you tired another USB cable? Otherwise, there might be a specific setting in Windows which has to be enabled first. Thanks

Thanks for the quick reply.

I’m using this version of windows:

Edition Windows 10 Pro
Version 22H2
Installed on ‎10/‎11/‎2020
OS build 19045.3570
Experience Windows Feature Experience Pack 1000.19052.1000.0

I’ve tried multiple ports on my PC, all connected directly. No USB hub.
I have tried several different USB cables, all of which work without issue for other devices

Hi @carlinplumb!

I’d suggest restarting the computer before point 1. of the Reproduction Steps. Alternatively, after point 2.
After that, the Ableton should be able to recognize the Mini.
Let me know if it works :slight_smile:

As a side note, make sure to install the ASIO4All as well.

Hi Borsuk,

I have completed both of those examples but it will still not recognise the Mini.
ASIO4ALL is installed and selected.
In the hardware config panel of ableton the Polyend Mini does not come up as a routing option in ASIO4ALL.
The Mini is connected to a working, direct in USB port on my PC using the supplied cable.

are you using the USB cable that came with the Tracker Mini?

Yes I am.
I have also tested the cable I use for my audio interface that I know works for the same purpose

I can now confirm that I have tested the Mini on multiple PCs and a MAC and it still not available as any sort of audio inputs.

Can you confirm if there’s any config options I may have missed?
Is it as simple as plugging it in and good to go?

Is it possible there’s an issue with my unit in particular?

In that case, it sounds like a hardware issue.
Please fill out an RMA application found here: RMA Application Form - Polyend
After doing so, I will take it from there and contact you via email.

Just a mention in case: Sample rates and buffer sizes much match according to this article.

Must match what?
The Polyend, Ableton and my Audio interface must match?
Polyend Mini is 44.1, but what is the buffer size and where is that information?

That article also suggests installing an older version that works with Windows 7 for some reason.
I have windows 10.

The way I understand it, sample rates and buffer sizes in windows or in this case asio4live config must match with whatever sample rate the tracker outputs…I’ve fiddled around with this an entire night with only partial success and also tried the option force windows WDM to 16 bit (there’s a small checkbox). When you get into your daw to record, well that’s a whole other ball of wax. I don’t like this method And I feel the best way to record the output directly is simply to export your stems inside the tracker and transfer them via SSD into your daw for doing further work or, if you need to record the output directly use the line out and midi in/out through your sound card’s interface and or midi interface so you can sync to tempo. I wish some other users that have had success with USB on PC would chime in and give us a little TUTO to help with those of us that are struggling. P.S. I’ve yet to try this on my MAC.

I found this and made progress using the following method.
To create an aggregate device in Windows without using ASIO4ALL, you can use the built-in Windows Audio Session API (WASAPI) 1. Here are the steps:

Press the Windows key + R to open the Run dialog box.
Type “control mmsys.cpl” and press Enter to open the Sound settings.
Click on the “Recording” tab and select the devices you want to use as inputs for your aggregate device.
Right-click on one of the selected devices and choose “Properties”.
In the Properties window, click on the “Listen” tab.
Check the box next to “Listen to this device”.
Select your output device from the “Playback through this device” dropdown menu.
Click “OK” to close the Properties window.
Repeat steps 4-8 for each device you want to add to your aggregate device.
Once you have configured all of your devices, right-click on the Sound icon in the system tray and choose “Open Sound settings”.
Click on the “Output” tab and select your aggregate device from the list of available devices.
Click “Test” to verify that your aggregate device is working correctly.
Please note that not all devices are compatible with WASAPI, so you may need to experiment with different combinations of devices to find one that works for you 1. If you encounter any issues, please refer to the user manual or contact the manufacturer’s support for further assistance.
It didn’t work for me word for word as its mentioned here.(I’m in Windows 11) I had to phish around for the settings a bit before I found the part where it says listen to this device. Then I chose my External sound card for the output and it worked. The sound quality was good as well.

Hey Eric,

I think you might be misunderstanding what my issue is.
I cannot see the Tracker Mini as an input at all.
If I plug it in via USB on the computer it will charge, but it is unavailable as an input on the PC, in Ableton, in ASIO4ALL, nowhere to be found. I can’t aggregate it, because it doesn’t seem to exist.

@carlinplumb Arrived here to start a similar thread when I found yours. Roughly same setup over here (tracker mini, oem Polyend usb cable, into windows 10 home pc, running ableton 11.3.11, asio4all 2.14) and same problem. Ableton preferences not showing Tracker Mini as an input option. Following this thread in case anyone has any bright ideas. I do see there is an asio4all 2.15 version available these days, I may upgrade to see if any difference…

@jibbs1234 As it turns out the initial bug was a hardware malfunction.
I will close this topic.
Please start a new thread if you still have problems with your Mini.