Play Plus SD card not readable after adding sample packs

Bug Description

After adding in palette sample packs or my own packs onto the sd card and ejecting it from my computer, i put the card back into the play plus and turn it on only to have a message popup that says insert sd card. I have tried ejecting it while off and reinserting it only to get the same message. After trying to put the card back in my computer it tells me that the card needs to be reformatted and all data will be erased,

Reproduction Steps

  1. put sd card in the supplied card reader from polyend and place in computer
  2. copy sample packs into sample pack folder
  3. eject sd card from computer
  4. place sd card back in play
  5. have “insert sd card” pop up
  6. take out sd card and put back in computer with “sd cards needs reformatting” message


almost always

Found in

This has been happening since 1.0.1 im not sure what the current build was as i had to erase everything on the sd card

Hi @bcrane780 Thank you for reporting this bug. We are sorry you’re experiencing issues while using Play+.
Just to clarify, the Occurence is “almost always”. Did this also happen after formatting your SD card?
Have you tried it with a different SD card?
According to your description it seems very likely that the SD card is at fault here.

Additional question: which card reader are you using?

So it will happen after reformatting if I try to eject the sd card. This problem only seems to be avoided if I forgo ejecting the as card and just pulling it out of my computer. I don’t have a different sd card to try it with and I only use the sd card reader that was included with the play plus