Play+ not recognized by Expert Sleepers FH-2

Bug Description

Polyend Play+ and Expert Sleepers FH-2 not communicating with each other. Worked perfect with the Play, but not working anymore with the Play+.

Play+ is hooked up to the FH-2 via USB, receives power from it and boots up, but is not recognized by the FH-2 as a class-compliant USB device. Firmware on both devices are up to date. FH-2 recognizes any other USB device (e.g. Arturia Keystep). Play+ has the correct settings and works fine with an ipad (for example). Tried multiple different cables to no avail.

Reproduction Steps

Connect Play+ to FH-2 via USB cable. FH-2 normally gives instant feedback with showing an “A” in the USB indicator section at the left side of the display - doesn’t do that with the Play+ and does not receive any midi from Play+.


Always happens.

Found in

  • Version: 1.0.1
  • Build: 1405

Some problem here with a Play+ I recently acquired with latest firmware 1.0.1 installed.

Tested with 1010music blackbox and Tubbutec USB Bridge A Eurorack Module.

This must be fixed asap guys, such a basic feature, come on.

Try to put a usb hub in between?