Play Midi problems

New Play owner here. Enjoying it very much so far, but Midi has been a nightmare.
I got 4 synths hooked up to the Play on the correct sending and receiving Midi channels. Play is set to send Transport messages and Clock messages.

I only can get one synth to work consistently. The other devices don’t respond 90% of the time.
Every now and then it plays a small part of notes I have sequenced, while skipping over other notes.
It’s driving me mad.

I’ve tried fiddling with different notes, as I assumed the sequenced notes might be out of reach of my external synths. This worked once very briefly and I had a full sequence running.
Once I paused Play, the problems returned.

I have been trying to figure this out for several hours now, can anyone point me in the right direction please?

Volume levels are up, chance is set to play always, every external synth is receiving clock from the Play, note length is set to 1 on each step.

1 Like

Hi! How are you connecting the synths to the Play?

If you can reproduce this problem, we could turn this post into a Bug report.

Midi out from Play to Midi in of a powered Midi thru box, which then goes to each synth I have.
I have also tried connecting Midi out from Play straight to Midi in from my other gear, same problems occur.
Someone on Reddit said they experienced the same problem.


  • Behringer Neutron → works as it should every time
  • Behringer TD3 → managed to get it to work 1 time, but also with certain note skips. The light on the TD3 which is supposed to be lit red, was flashing between red and green. Something I have never seen before.
  • Korg Volca kick → works 50% of the time, but skips notes every now and then, not always
  • Donner B1 → doesn’t work at all

After some more troubleshooting, I’ve resolved most problems.
Issue was sending clock to the external synth, which prevented them from sending audio to my mixer somehow.

The TD3 however still skips most notes while playing a sequence. The weird thing is the notes it skips change every time the sequence repeats.

Since you have a MIDI Thru box in between. i’m guessing you are going from TRS to DIN ? And everything else afterwards is just DIN?

If there are direct TRS connections, make sure that they are in the correct version. The Play (all Polyend devices for that matter) are TRS B devices.

I am using the trs dongle which came with the Play, so should be good on that end. After the thru box everything is DIN yes.
Just discovered that when I put repeats on each sequenced note, there are significantly more notes played (still not all of them though), and when slowing down the tempo that number even increases.

The Play just completely froze while playing the midi sequence. As much as I like this device in general, I’ll be returning it sadly.