Play + encoder values jittering constantly - unit is unusable

I honestly haven’t used my unit a ton - a few times a week since christmas. for short amounts of time. I usually make a quick loop - record the audio and work around that - for now.

Suddenly The unit has become virtually unusable - and so much that i can’t even reset the unit or upgrade the firmware because the unit is being triggered somehow sporadically and making it impossible to use any of the encoders.

The volume for instance right now keeps going from -inf to 84 db in a very non rhythmic, glitchy manner. I’ve tried going direct usb-c / using the factory power cable and supply into a furman. Nothing seems to help at this point.


Hey @levonemmons, welcome to Backstage! :partying_face:

Sorry to hear that you are having issues with your Play+.
This issue has come up once or twice so far. Check out this thread (and the specific comment i linked to) as Polyend has some info that might help you there:

If not, feel free to contact their support and i’m sure they will help you out. :blush:

1 Like

So - i just wanted to make sure to follow up here. I got done with work today - busted out the play + and tried what you recommended.

Firstly - i should’ve been more aware that it was reverting to “jittering” on the volume knob / command. So i would press any other knob / control and it would switch back to the jittering volume selection. As of right now it’s working - and i’ve just successfully updated the firmware.

Thanks so much for the help and suggestion.