Play+ doesn‘t turn on anymore

It seems my Play+ refuses to turn on correctly since today. I use the same cables and supplies as yesterday when it was working fine.
Has this happened to anyone else already?


Did you try using a different SD card with a fresh firmware install?

@JimP4nsen Thank you for reaching out about this. Before we go any further, please try using different cables and power supplies (including powering it up via USB on your computer).
If it doesn’t help, please fill out the RMA Application Form • Polyend
Once you do, I will contact you directly regarding the next steps.

I tried different cables and supplies which didn’t help. Removing the SD card actually worked, it is now working again. Even after inserting the SD card again it keeps working.
Is there anything I have to keep an eye on?
To be honest I never had these issues with the OG Play :pleading_face:

1 Like

Looking at how beautiful your picture above is, maybe your Play+ reached Singularity and wanted to show you with a celebration…

1 Like

Picture looks AI-generated.

That explains a lot. It must be related to the SD card.
I’m closing this topic for now, but please let me know in case of any similar issues in the future.

This topic was automatically closed after 7 days. New replies are no longer allowed.