Play+ audio over USB crashing my computer

Anyone out there having issues with the audio over USB?

When Play+ is connected directly to my computer (Macbook Pro running Ventura 13.4.1) using a USB C to USB C and I open Ableton, I can see “Play” pop up in the audio settings for in / out but it keeps dropping out and popping back in. I can’t even get to the section to start turning channels on, it just drops in and out.

So I set up aggregate as it’s suggested in the manual and while in this configuration set up, I can see “Play” dropping in and out as it was in Ableton. After re opening Ableton and selecting the new aggregate device it seems to connect ok but as soon as I hit start in Ableton, I can hear slight audio glitches and then…my computer crashes! This has now happened 4 times in a row while trying to select “Play” aggregate in my audio settings.

For the record, I have tried 3 different USB cables, rebooting Play, my computer and audio interface in different sequences and I still end up with the same results. I’ve never had such a hard time setting up a device in my life! hahaha

Has anyone experienced this with the Play+ ?

Am I missing a step or something ?

Thanks in advance!

So I just tested this on an old MBP with Ableton and everything worked as expected.

Because I can see it dropping in / out in the audio midi setup page, I can rule out it having anything to do with Ableton. So I decided to update my OS from 13.4.1 to 13.6.1 but sadly I still have the same issue. I’ve also flipped between the firmware 1.0 and 1.0.1 without success.

Could you share what OS your older MBP was running?
Sadly don’t have any Mac here to help you with.

It’s running 10.11.6 on a 2009 MBP :exploding_head:

I did not expect it would work on something so old – that was me giving that suggestion on facebook! Now why on old one, but not new one? :thinking:

I had no sound yesterday but today now I do but I have the same issue you described. The audio plays but then breaks with a pop or click and resumes. The break in sound is very prdicatbale at 12 seconds or so while Playing the Ambient demo at 90 BPM.
Live sees all 28 inputs from PP Oddly, I found the recommended direct connection to my Mac M1 mini was not recognized but using my USB C Hub it did see the Play and all the outputs…but also discovered the Play does not get clock in from Live when I chose Clocking over USB…the Play does nothing. Yes, I checked Transport In over USB also.

I’ll keep troubleshooting today and let you know if I find a fix. At least I have made some progress from no sound to this state.
Mac OS Sonoma 14.1.2
Live 11.3.13
Mac mini M1
USB Hub Amazon.com
https://a.co/d/f3XwD6q

OK, I think I found what my issue was and perhaps its the same type of thing for you Antone.

The setting for sample rate in Live should match your Aggregate device Sample rate.
At least for me this seems to have worked. My audio is playing uninterrupted and sounds great! Hope this helps…or at least one more item to eliminate.
Cheers

1 Like

My issue is that even when I have the audio midi setup open, I can see
“Play” and than it disappeared…and than reappears…and than disappears. It just keeps dropping in and out and the same goes for when I open Ableton. For whatever reason it seems to struggle keeping a solid connection and this is where a conflict occurs and I get crashes.

How many other devices are you using on your USB ports…this sounds like power dropping out. If you can disconnect all bus devices just to test this thought it might help.

This dropping in and out was happening to me on an iPad with a hub. I thought it was because of the hub. But sounds like it might be related to a sample rate conflict.

I have two USB C ports on my MBP and only have Play+ plugged in at a time and it drops on both ports. When I have anything else plugged into the ports and look in the audio midi setup page…none of the plugged devices drop in and out like the Play+ does