Play+, Ableton USB audio glitches


Bug Description

Audio over USB-C fails after a little while.

Reproduction Steps

Play+ firmware 1.0.0 via USB-C to Ableton on MacOS 14.1.1.

Routing configured in Prefs > Audio > Input Config, just Stereo 1/2 selected.

Turn on monitoring in Audio track.

Hit play on Play+. Music goes through just fine.

Hit stop, a bit later. Instead of fully stopping, the Play+ sends the last ~100ms of whatever was playing, over and over again. At that point, the feed is fully wedged: nothing I can do will fix it other than disconnecting the USB-C and starting over.

Occurrence

Has happened four out of four tries, so far. Reliably happens as soon as I press Stop.

Found in

Play+ firmware 1.0.0 via USB-C to Ableton on MacOS 14.1.1.

official firmware 1.0.1 is out of beta as of today. I’m not sure if that will help this problem but it’s the new official firmware now. 1.0.0 had quite a few bugs apparently. it might be worthwhile updating & checking the usb audio again.

1 Like

I’ve this exact same problem.
I’ve tried it with Ableton and Logic.

Resetting the audio driver helps for a bit, but then it goes again.
Just updated to 1.0.1. It didn’t fix this issue.

Thanks for trying this. (I haven’t had a chance to get back to it, update firmware, and test on 1.0.1.)

Bummer!

I wonder if there is a way to gather debug logs to help Polyend sort out what’s going on here.

1 Like

The best thing you or anyone can do (for any type of bug) is:

  • provide the project file (if applicable, speeds up testing)
  • write down detailed instructions, that reproduces the error.
  • or record a video detailing all the steps taken to reproduce the error.

That’s all that is necessary really :blush:

1 Like

Hi @benbrantley and everyone @here, thanks for reporting the issue and your comments.

First of all, please try following guidelines about general issues related to “Audio over USB”:

They can be found in Release Notes above, under KNOWN ISSUES: point about “Audio / MIDI over USB”

Please let us know if this fixes the problems. It’s also worth saying there are two other known issues logged in Backstage related to USB audio:

Besides this, general audio playback and recording over USB should work well if you follow the guidelines already mentioned. If you’re still having issues, please log a Bug with more specific case(s) when it fails.

Unfortunately, we cannot reproduce this case. It might be related to the project or settings you’re using. Please attach both here and we’ll try to investigate further.

Thanks for your support

Hi there!

Same problem for me. I can read and listen the samples in live 11, but as soon I press play, the sound freezes. MacBook Air m1 Live 11.3.21
FW 1.0.1

Hi @quiniou.guillaume , thanks for your comment. Sorry for the troubles. Did you try to follow the guidelines under known issues in release notes? Which macOS are you using? Thanks

Hello,

Thanks for the response. Now after aggregate Play+ and Motu M4 it’s stable

Thanks for the update @quiniou.guillaume , glad it’s solved for you.

What about others @here, did you manage to fix the issues?