Midi Offset has coarse range in lower parameter values when device is also synced externally via USB

Bug Description

Midi offset for latency doesn’t seem to work great. If I go from 14 to 15 it jumps a lot and hard to fine tune to be on grid in daw.

Reproduction Steps

record synth on grid in any daw and try to get on grid under a 512th note. Very hard needs to be more granular.

Occurrence

all the time

Found in

go to Config > Firmware page on your device and copy version / build numbers below

  • Version: 1.0.1 Open Beta
  • Build: n/a

Attachments

Please fill out the missing Firmware version that you are using.
Are you using 1.0.0 or the open beta?

1 Like

Hi @djowensands , sorry you’re having issues with Tracker+. We are having a hard time to understand what are you trying to do: could you please explain in more details:

  • are you using Clock in or out from Tracker?
  • if yes, which option: USB or Jack?
  • if you’re using Clock in: are you using Clock sync correction in Tracker Config also?
  • are you using any MIDI offset / latency setting in the DAW itself?
  • are you setting Offset of individual MIDI Instrument Parameters in the Tracker?
  • are you recording MIDI / Synth / Audio in the DAW?
  • could you explain a bit more what you mean by 512th note?

In general, detailed description of how you’re syncing and recording the notes would be very helpful to help you resolve this issue.

Its being clocked from bitwig over usb. Midi Notes are sent to bitwig using usb then to external behringer pro 800 over usb again and audio from pro 800 being recorded to audio channel in bitwig. For reference I do the same with my hapax and using its midi latency correction(+8ms in this case) on that midi channel can get it bang on the grid. I can get it pretty close with the tracker + but it seems its not granular enough and 1 increment jumps way too much. It almost seems like 0 to 14 doesn’t move it at all or very little and they it jumps too much going from 14 to 15. Its weird behavior. What is the unit of measure for offset? ms I assume? Also another thing to note maybe is that I am using config>> midi> clock sync correction set to 2(coupled with a bit of clock offset from bitwig) in general to fix the overall synch of the device to be on grid in bitwig when recording the sample tracks from tracker +.

Also yes its the midi offset under instrument params for midi track. Also the 512th note is at 133bpm(or .004 seconds or 4ms) but that is really irrelevant as its all really relative to the fact that it seems to not be granular enough to get it closer to the grid. I usually accept a 1024th note or less to be close enough for my taste which can be different ms or samples depending on bpm.

I like to keep my stuff tiiiiiiggggght! :slight_smile:
Its really good that you acually offer this offset param in general though. Not alot of devices offer this much needed feature. LOOKING AT YOU AKAI FORCE!

Hi @djowensands , thanks for detailed explanation. MIDI jitter around 4ms is acceptable for us and we cannot guarantee better syncing than that, I’m afraid. Clock sync correction unit of measure is explained in the Config screen, please read the description there. Otherwise, I’m sorry we cannot help you get a tighter sync, it seems to me you’re using all adjustments which are possible and correctly :slight_smile: I will close this issue “by design”. Once again, thanks for your time and support.

It has nothing to do with midi jitter. It has to do with the offset param not having enough granularity or just not working right in general. Midi jitter is when the average of the note placements fluctuates by a certain amount. This offset is for moving everything forward or back in time. It honestly just seems like it doesn’t work. I will give it another try but my initial tests seemed like the setting just didn’t move the notes consistently. It was definitely not jitter.

1 Like

Hi @djowensands , yes, you are correct. Now I understand. What I was trying to say is that we cannot guarantee better MIDI precision than 4ms in general. Maybe it’s the setup itself that causes the problems: having multiple “sync” corrections which don’t work well together. I will talk to the team and get back to you with more details.

yeah also again its not the config >> clock sync correction param. Its the midi offset param on the midi instrument page. So use a midi instrument and then press instrument params and its the second param from the left called “Offset”. And I cant find anywhere in the manual or on that page that says what this is unit of measure is. I would assume its ms. And if it is ms its incremental by 1 so in theory you should be able to get within ± 1 ms to the grid.

Here is a screenshot going from 14 to 15 on that setting and this time I set the clock correction in midi synch menu to 0 to remove that variable.
If you look up in top left on bitwig you can see the time where I have highlighted is .018 seconds which is 18 ms. Also every where in between 0 and 14 doesn’t move the notes pretty much at all. very slight moves compared to moving from 14 to 15.