How to get Tracker+ working with JACK on Linux

I feel that it’s possible, but the only option I see is Tracker+ as a MIDI device in QJackCtl. If you’ve figured out how to get the audio from Tracker+ connected to Linux, please share.

Hey @chrisr, can you confirm that you have set up USB audio in the Config/USB menu on the Tracker+ please? Much appreciated :slight_smile:

Hi Dan. I have configured that in the Tracker+. I’m able to connect it to my Windows computer, but not my Linux

I’d take a look under the hood with a tool like Patchage:

Might provide some insight on what is visible to Jack. I’m fairly certain it should show up since the tracker is class-compliant.

Edit: re-read realized this was for audio, and MIDI was already visible … but I still think it might be worthwhile to try since there a lot of moving pieces with Jack (this post gave me flashbacks to my Linux days).

Could also be a distribution or library thing. Maybe audio requires some other dependencies, but that’s beyond me.

I had the same issue. Alsa recognised the tracker+, but anything higher (pipewire, pavu, qjackctl) only saw midi at best. I updated all my installed packages to the newest version and then rebooted with the tracker+ connected and powered on. After that it was recognised.


Thanks so much for sharing @Gtantha and a warm welcome to Backstage!

1 Like

I found I had to set the tracker’s USB audio setting to “input + output” to see the many output channels from the tracker that Gtantha’s screenshot shows. The “output” setting alone did not work for me.

This is indeed a little confusing:

  • Input refers to the channels that are sent out (for multitracking) from the device
  • Output refers to whatvever is sent back in for “output” of the line-out of the device.

If you don’t want a headache: just choose Input + Output from now on.
It will prevent you from getting just as confused as me :laughing:

1 Like