Contact support page not loading

Bug Description

The form for contacting support doesn’t load in My Account when i’m logged in. This has never worked for me and i’ve tried on several different days.

Reproduction Steps


Has never loaded for me

Found in

Website - My Account - Contact Support


@edmundxwhite Thank you for reporting this issue. At this point I was not able to reproduce it. Could you provide more information about the issue?

  1. What operating system are you using?
  2. What is the browser you are using (including its version)?
  3. Do you have any browser Addons / Extensions / Plugins installed?
  4. If you are able to open the browser Console (available in the Developer Tools of the Browser, which are usually accessed by pressing F12) - are there any errors being displayed in the Console?
  5. Have you encountered this issue on other devices / browsers?

UPDATE: This response has been marked as a solution by the original poster due to the bug being resolved by disabling a Tracking / Third Party Request Blocker browser extension.


Thank you for the troubleshooting help. It was a browser extension that blocks tracking requests and third party requests. When i turned off protection for the page, the support form loaded. It must have not liked something in the live agent iframe. I am back on track, thanks again.


@edmundxwhite That is great to hear. Would you be able to share what browser and extension it was, so I can see if there is anything we could do about this issue? If you do not feel comfortable sharing this information publicly on the forum I would greatly appreciate if you could send it to me in a private message.

1 Like

Hi @Maczek, it is the DuckDuckGo Privacy Essentials (it checks for encryption and blocks some third party requests). I saw the same behavior in FireFox and Chrome with the extension. By turning off the essentials for that site specifically it worked as expected. Hope this is helpful.


Thank you for that addon name, we will see if there is anything we can do about it blocking the form, in order to improve other users’ experience.

I can reproduce this problem as well, with the Privace Badger plugin. It detects two trackers that make the page not render correctly:

@icaria36 what kind of rendering issues are you experiencing? Blocking these trackers should not alter site rendering, as far as I know.

See the screenshot, and I have sent you the Browser inspectors’ console output.

I have added a fallback message that displays when the support form is blocked, hopefully this will alleviate this issue in the future.

Unfortunately I have not been able to reproduce the issue, @icaria36 has been experiencing - Privacy Badger blocks the same trackers in my testing environment, but these trackers being blocked has no effect on contact support form loading.

1 Like

Hm, actually you are right. I disabled the Privacy Badger and… the form doesn’t render either. It seems to be another problem.

I don’t know, but here is my browser version just in case it helps:

Version 110.0.1 (64-bit)
Mozilla Firefox Snap for Ubuntu
canonical-002 - 1.0