Bug: Play v1.4.1 freezes when exporting "Current Pattern Stems"

Bug Description

I have a little project and whenever I go to Settings > File > Export > Current Pattern Stems the progress bar doesn’t progress and the Play just freezes.

Reproduction Steps

  1. Start up Play
  2. Load project
  3. Go to Settings > File > Export > Current Pattern Stems
  4. :infinity: … Have waited 20 minutes+ I have to pull the plug and restart the Play to get it to become responsive again.


Always, for this project.

Found in

  • Version: 1.4.1
  • Build: N/A?


Happy to provide the project, privately, to Polyend staff.

On the SD I get zero-byte WAV files.

I tried loading an earlier “Save As” of the same project, with fewer samples, and it also freezes.

When I try exporting the factory demo project “Acoustic”, that works.

Have sent the project through to support, for testing :v:

1 Like

Hi @peter-9486 Thank you for reporting this bug. We are sorry you’re experiencing issues while using Play. We will do our best to resolve it and notify you when it’s ready.

1 Like

Hello @borsuk! Thank you so much.

I solved it, I think! After trying lots of things related to samples and filenames, I realised that my project had one midi track. When I delete the track… the export works!


@peter-9486 It also worked for me. It will help us a lot. Thank you :slight_smile:

@borsuk you’re so welcome. Thanks for creating this awesome machine.

I tried creating a new project with audio and a single midi track, but that didn’t trigger the bug. So… it seems to be something about the midi track in my project, specifically. Not sure what… :slight_smile:

Ah, @borsuk, I probably know what happened! I had copied audio (sample) notes to my midi track! So maybe something audio-related got copied along, making the export try to export the midi track, and hence freeze?


I’m getting the same issue. A pattern with a mixture of audio and midi and it hangs on export.
Unplugged the midi cable…same result.
Tried saving the project and deleting all midi data and it exports the stems okay…if a little glacial.

Bit disappointed to be honest. For me it’s limiting.
Imagine if Play exported the midi data too…that’d really open up this machine for some serious work.

@here I’m glad to inform you that this bug was fixed in the Play 1.4.2 firmware update :slight_smile:


This topic was automatically closed after 7 days. New replies are no longer allowed.