Beginner using a DAW for first time

Hi there,

I typically work completely in the hardware and export full tracks when I finish.

Currently, I’m working on a small game, and need to export individual patterns to be looped internally by the game engine (Godot).

When exporting patterns, I notice they have trails and do not loop perfectly.

Are there any suggested tips for working with this?

On other forums, I have been told to record the loop playing 3 times, then slice out the middle loop, and use that file. I’m getting clicks when I do this, and noticing that the loop isn’t falling exactly on the step/beat in the DAW (Garageband/Audacity/Bitwig).

Would love help, resources, manuals, anything to get me going. I don’t have any LFOs or FX active. I’m using a kick drum sample and an internal synth.

Ideally, I don’t want to spend a large amount of time learning the quirks of a given DAW, but if there are no easy answers, and I’ll need to learn the DAW deeper, I can do that.

I would second their “loop 3 times” suggestion if you are looking for a clean and simple loop.

What is your issue with the loop being out of time? Is it clock flutter from the Tracker, BPM mismatch, or just needing to manually line up the loop in the timeline?

Nevertheless, to best get the loop in time, I would use Bitwig as the clock source since you are doing your chopping there. Go to settings → synchronization, and enable your audio interface for MIDI sync out. Set the Tracker to receive clock and transport via MIDI. Connect cables accordingly, then record as you were before, just using Bitwig for start/stop. Once recorded, you will probably need to manually line things to account for clock delay (probably a few milliseconds).

Now: to get rid of the clicking (quick and dirty). Highlight your desired section, and use cmd/ctrl+J to ‘consolidate’ the section. Zoom way in on the waveform in the track view, and place your cursor on the very top-left of the section, and you will see a white triangle:


Click and drag the triangle a small amount to smoothen the start:


Do the same for the end of the loop:


That should do it. Hope it works out. :slight_smile:


Well golly gee-whiz. This has produced the best results so far. I’m so so thankful for your time and effort in responding. Been sweating for 2 days trying to get this to work in any of the 3 DAWs mentioned. Thank you again.