Background noises/glitches from samples firmware 1.7

I just run the new 1.7 firmware on my Tracker and I heard some background noises/glitches from samples (only one side, l
eft or right) in particular on vocals/melodies

You can hear it from all the Tracker’s modes (Loader, Playback, Editor, Parameters, exc.)

I already verified with all my headphones.

Bug is reproducible always

Firmware version: 1.7.0
Build: 533

Hi @anna.giuglietti , sorry you’re experiencing issues with the latest Tracker release. We are not able to help you or understand the problem without clear reproduction steps. Could you do an audio or video recording of the noises or glitches which are problematic? If not, please zip and attach the samples and/or projects which have these issues and along with your config settings file and we’ll try to reproduce the issue ourselves. Thanks for your support!

Hi and thank you for your availability!

I tried before to upload a zip file but the website didn’t allow me to do it, now I can!

There’s no reproduction steps for the bug, in my case the audio just coming out like this:

Tracker Issue (1.9 MB)

Now I’m running the 1.6 and audio is perfect.


Perhaps unrelated, but wonder if this is similar to what you are experiencing…

I have a bunch of kawai K1 single cycle waveforms that are glitching in a very odd way, not looping sounding almost time stretched in sample playback editor (worth recording actually, good sample fodder)

I also have some of the adventure kid single cycles that play perfectly, only difference between the two is that Adventure kid single cycles are 16bit and the kawai are 24bit…will explore more and report back, both worked perfectly on 1.6.

For curiosity sake, could you make the same recording in 1.6, so we could hear the difference? And if possible share the project with us? This way others (like me) with the tracker could test to see if the behaviour is the same.

Just listened to your audio example, mine is an unrelated issue. Good Luck.

Thanks for the info. As far as we can say, this sounds perfect also as we don’t have a reference of what you expect it to sound like. Can you please upload how it sounds in 1.6? That way we can understand more about the problem you’re experiencing and hopefully fix it for you.

Once again @reubenfinger sorry about the problems you’re having. Please log a separate Bug report ideally attaching the files which are problematic and saying when the problems occur. Thanks!

I also noticed samples have some noise associated with playback - sort of like a very small amount of bit reduction. I double checked that bit reduction was turned off on all the samples I demoed and also played around with other settings but the noise is still there. Just listened to your audio example though and I’m not sure it is the same thing. The audio on your example almost sounds like the saturation mode has been set to overdrive and is peaking.

Hello @Sandroid and thank you for your availability!

Unfortunately this bug isn’t in a specific project; as @ESDB describes below the sample preview or playback sounds like with bit reduction/overdrive.

@miropoly now I loaded a zip file with the two version of a sample preview, one via 1.6 and the other via 1.7.

Tracker Audio Issue (3.1 MB)

Thank you in advance to everyone!

Hi @anna.giuglietti , thank you so much for the support so far. We can finally hear the distortion in one channel which is not present in 1.6 version. But we haven’t run into this problem on any of our projects.

If would help us tremendously to find out what’s wrong if you could upload any project folder which has this issue. Just zip it and attach here, or send it to me via private message (if you don’t want to share publicly). I will keep it only for bug investigating purposes.

This will help us a lot to search for this problem ourselves: it might be about they way you’re using specific features, specific samples or project config setting or a combination of all of those.

Thank you for your help and patience!

1 Like

Goodmorning @miropoly , I apologize for my delay but I had troubles with internet connection.

In these days I tried again to upload the 1.7 and this bug disappear finally but I hear quite differences between sample reproduction/management (like leght, decay, delay, exc).

For example respect the previous firmware, I can hear delay and fx Tempo work a bit differently, in particular on some projects that I’m working on.

Anyway if could be helpful I can send you via private message my project folder; I save them with both firmwares version.

Thank you for your help!

1 Like

Good morning @anna.giuglietti , thanks for getting back to us. We’re glad to see you re-connected :wink:

I’m also glad to hear you’re not experiencing this issue anymore, but I find it really suspicious that it would “just” go away by itself. If you ever still manage to reproduce it, please inform us opening another bug report. I will close this one in the meantime.

Please check the release notes BREAKING CHANGES section: delay has been redesigned and WILL sound different in 1.7 as announced. If you don’t want this, we recommend finishing current projects in 1.6 before moving onto 1.7 release. Tip: you can also save them with “1.6” name tag, so you will always know they have to be loaded in this version to sound correctly.

Also, Tempo FX have had changes as well and will behave slightly different: please read FIXES section in release notes for more info and let us know if you still have questions.

Thanks for your private message, I will check your projects and write you there.

We appreciate all the info you’ve given us so far, thanks for you support!


Thank you really for your availability and patience!

I thought infact that these were improvements but after these issues I wasn’t able to understand/recognise if they were other bugs.

I really love how you gained the sound space; now is really immersive!

Thank you for you work :cupid:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.