Any updates on MIDI sync jitter?

I know there have been a ton of threads on this already, and I’m not trying to beat a dead horse, but MIDI clock sync has been a pretty terrible experience for a lot of us. I have really wanted to put the Play at the center of my drum sequencing workflow, but the MIDI jitter/“No External MIDI Clock” within 20 seconds of transport start kills it for me and I’m very close to giving up and just jumping to an Elektron Digitakt for my sampling needs.

So far the only consistent answer has been to use the Play for the Master clock (which isn’t detected to begin with) or to buy a MIDI clock as opposed to using the DAW sync (not including all of the USB hub power settings, which are already configured appropriately). Really disappointing responses, considering I couldn’t stop raving about the Play workflow months ago. It’s the only device I have MIDI issues with - I’ve got a Prophet 10, Moog Subsequent 37, Minibrute 2S, and NI Komplete Kontrol S88 all syncing to Ableton with no issues. Directly connected to computer USB - no dongles, and I’ve tried switching multiple ports.

I have gone through all the appropriate settings with MIDI, so it’s not an issue of Play settings being misconfigured. This seems to be a trend if you read other forums as well (reddit, elektronauts, etc) and I’m wondering if some of the sync issues with the 1.7 update for Tracker would have some overlap with this.

Is there light at the end of the tunnel, or is all focus on the Tracker Mini at this point? :cry:


Just to offer another perspective… I have been using the Play as clock master and slave, with Ableton over USB (via a hub, using macOS) and also with a Hydrasynth (via DIN MIDI). These scenarios have worked without issue, for me.

Of course you’re mentioning all the other gear that you’re not experiencing sync issues with, so I’m not wanting to downplay your experience and its real issues. In comparison to your other gear that does work, there might indeed be some improvements that can be made to Play to make it sync more solidly.

I wonder if it’s a USB cable or hub issue, for you, or a combination thereof. Hope we get to the bottom of it, as the Play is indeed a wonderful device. And, midi is… sometimes… quite annoying.

Have you tried a few different minimal setups, e.g. just the Play connected directly to different USB ports on your computer? Tried a different cable? Tried isolating the issue? :pray:

Thanks for chiming in. I’ve tried everything you mentioned - the only thing different in my scenario is that I’m on PC. In addition to any previous mentioned optimizations, I’ve tried to ensure everything is on different channels, tried switching all the connections, and tried ensuring all other MIDI devices are turned off.

I’ve had the Play since the middle of February and haven’t been able to get stable MIDI clocking since then, and not for lack of trying. It’s just frustrating - I’m really not trying to dog on anybody here, and kept telling myself “maybe it gets sorted out in firmware” but here we are 8 months later and facing the same issue.

That’s no good, I’m sorry that I can’t be of more help. It sounds like you’ve done some thorough debugging, which nobody likes doing instead of playing and creating. I hope that someone else can assist here.

i experienced the same MIDI jitter when i bought the tracker months ago. the timing is so unreliable in my DAW that its almost impossible to use it.
at first i worked around it by recording my short tracker patterns 20 times in my DAW to pick the ones which are most stable :wink:
but this is tedious, and i have tons of other hardware boxes without MIDI problems but since i love the tracker workflow i did not sell it yet, but kept it in the case until there may be good news according the MIDI timing.
i hoped for the last firmware update but it seems my tracker will still stay in its case.
its a pity, because for me the tracker could be the perfect idea tool for travelling and holidays…

That was my thought as well. I bought the Play before a few weeks in Japan and Taiwan and was initially extremely excited about the possibilities of sketching during travel, but found the MIDI issues to be a total workflow killer when reintegrating with a studio environment. I barely use the Play now - it went from having the potential to be one of my favorite products ever to being something that really frustrates me.

I wish someone from the team would give us some hope. I truly want to be a Polyend fan, and a little support would go a long way. I feel like these are the things that make/break a company in the long run, because they make the difference in whether or not we return as customers.

1 Like

Hello guys, I’m having the same issue, which is making the Play useless.
I found out that, whenever in external clock mode, it will lose sync if incoming data is contains several notes, the more notes it has the worse the jitter and the desync.

  • I’ve tried with and without MIDI thru boxes
  • I’ve tried together with a circuit tracks and other equipment, and the only one messing up is the play.
  • The issue can be reproduce with every MIDI option set to off except the clock.

Some videos:

I really hope this can be solved,

An interesting scenario - but that’s not what I’ve been seeing. Mine is more related to the playhead pausing, audio dropout and the error display.

Hey everyone. Just to keep the community updated - Mitch responded and is providing assistance in trying to resolve the issue. I don’t have any updates on the product roadmap or anything special to share, but I can tell you the answer to my above question is that the Play is still getting attention from the team!

Thank you Mitch!


Well I think it could be related. My theory is the the clock gets corrupted if there are more info coming from the midi port (MIDI notes in this case)

As an experiment, I filtered all data except clock and the Play does not glitch anymore, of course I cannot send data from my controller to record midi notes, but at least I can still use it.

Maybe you could try if filtering the MIDI data to just clock solves your issue.

Glad to hear you got a reply. I’m still waiting for support to reply after a few days.
A real shame, I had the unit for two weeks and still could not properly use it.

Can it be that this discussion has two parts?

  1. Midi jitter, which is a continuation of Is it possible to send a stable MIDI clock to the DAW?
  2. Problems like clock not detected, midi info lost, 20 seconds something something… Problems that should be reported and track as separate bugs.

We are working on a fix for the midi sync jitter. However, @baj your problem looks like more than a jitter so I’d recommend emailing support, which you’ve done, so I’d just wait for them to get back to you to help out!


When I used it with Cubase it was so bad I gave up, as well as with a Roland TR6S.
Now I just have the tempo set to Cubase and have the Polyend just receive the transport Start/Stop command. I cannot understand after so many updates why this issue still exists! It’s the only unreliable thing I own and everything else I have is clock driven and works perfectly. No doubt it’s going to be an issue in the new version too…

Is there an open bug/issue for the jitter problem? I’ve been trying to use the Play as the brain for my external devices (and I love the workflow etc), but the timing is too wobbly to record or perform with. I know other people are facing this issue as well. Frankly, this unstable clock issue is extremely disconcerting, especially as the OG Play is careening towards “Legacy” status…should we expect a fix?

We’ve still got some big updates for Play planned so I wouldn’t count on it headed to legacy status just yet. As for the bug fix - can someone log this as a bug report for proper tracking on backstage? Then we can post updates on the bug report there. I should have requested this logged there months ago but I’m not involved in QC so didn’t follow the proper reporting channels either.

@adam.pugliese , may i ask you to create a proper bug report in this case? I’m asking since everyone’s setup may differ one way or another. so it would be helpful to have the exact details of your setup and how you experience the jitter. This way others can add their setups and experience as well. :muscle:

1 Like

Hello @Mitch and @Sandroid, thanks for getting back to me. I opened a bug report

Please let me know if you need additional information.