Mac Studio not seeing Play+

Hey all,

My Mac Studio (running OS Ventura 13.4) isn’t able to see the Play+. I had no issues with the original Play connecting to this same computer. I’m wondering if anyone else has had this problem and, hopefully, found a solution.

I’ve tried it directly plugged into the computer and via a powered USB hub but no luck.

Hey @ben.j.greenspan and welcome to Backstage :hugs:

Let’s run through some common troubleshooting tips:

  • Do you see the device in the Audio MIDI Setup app?
  • Have you tried a different usb cable, just in case something is wrong with the provided one?
  • Are you running on the latest firmware?

Thanks for getting back to me!

  • It is not popping up in Audio/MIDI setup, unfortunately.
  • I tried a few different cables. Same result with all three
  • I am running the latest firmware.

Yeah that’s no bueno…

I would suggest to directly get in contact with customer support then.
I’m sure they’ll help you out. :heart:

I did this and the unit was replaced. Unfortunately, the problem persists. I’m not sure if it’s my computer or the firmware but I’m only able to sync the Play+ via MIDI.