Changing the midi channel instrument on multiple steps automatically previews the steps

Bug Description

When I have midi notes on track, I then select all the notes and change the midi channel/instrument, it automatically plays the selected part. I am not sure if this is bug or not, and it might be fine with sample instruments, but for midi instruments this behaviour has issues:

I scroll through midi channels, so it plays all the parts on my multitimbral synth setup, leaving notes hanging.
I don’t want to hear it randomly.
When there is no OFF message at selection end, notes are left hanging.

Solution for this would be to either disable the preview for midi notes or add an option in the settings menu to turn the automatic preview on/off.

Reproduction Steps

  1. Connect a synth or synths setup that has multitimbrality/multiple midi channels to tracker, such as Waldorf Blofeld.
  2. On any track, mark down some notes on desired midi channel and preview if you want.
  3. Select the part where notes are inserted and change the instrument/midi channel with jog wheel.
  4. It should now play the selection automatically as you scroll through midi channels…



Found in

Version: 1.6.0
Build: I don’t know.



Hi @Radiowaves, thank you for such clear bug report. This helps us a lot to react faster. I’m sorry you’re having issues with the Tracker but unfortunately this one is “by design”. Also I cannot reproduce it when Ableton is receiving MIDI for example, so I am guess it depends how the recipient (in your case Blofeld) is interpreting the incoming MIDI messages. Do you get the same behavior with other instruments? Either way, I would suggest to log this in our #wishlist as an improvement and we can take it from there. Possibly some people prefer the current design. Thank you for your time and understanding. Best regards

1 Like

It can still be a bit janky , but turning on the “transport” midi out on settings fixed hanging notes, so it is not that big of an issue it seems. Thank you for your reply.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.